Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Can no longer take Entire Part Studio as parameter

juliaschatzjuliaschatz Member Posts: 5 EDU
When the "Place Hole Profile" script "Part Studio" parameter has a filter of only ENTIRE_PART_STUDIO, then attempting to use this feature and selecting a part studio will simply report "No entities or features available." If I add any other item type to the filter (eg PartStudioItemType.ENTIRE_PART_STUDIO || PartStudioItemType.SKETCH) then I'm able to select the entire part studio as well as any components that match the other filter. The last time this for sure worked was in V90, with no changes to the code since then. Even when reverting to V90 the script doesn't work properly like it did.

I'm not sure if this was an intentional (silent?) change, or if I should file a bug report, or if I'm doing something wrong here.
Tagged:

Comments

  • korikori Onshape Employees Posts: 24
    Thank you for reporting this.  It is a bug and we are working on it.
  • korikori Onshape Employees Posts: 24
    This should be fixed in the latest release, please let us know if you are still seeing any issues.
Sign In or Register to comment.