Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Options

Boolean subtraction not working due to geometry

brett_jones039brett_jones039 Member Posts: 4
edited April 14 in Community Support
Hi there, I have a drawing that I'm trying to complete. Unfortunately, due to my lack of skill, I can't seem to get this to work. I know it is messy, but I'm so close! Just the last boolean is left. I wonder if anyone can help me get this to work.
Screenshot (couldn't get it to upload directly): https://drive.google.com/file/d/14Ot9FvcuLpCb2-RuxoMGYxB4JNIGli0r/view?usp=sharing
Link to drawing: https://cad.onshape.com/documents/e3f4fd9e920b1e569bc6d4b0/w/bdbc5a5e03c082ba6c435978/e/c36bc2c48633bcc3af229ccf?renderMode=0&uiState=661b7ffd79b42b4f5d88ea4b

Thank you in advance for any advice/solutions!

Answers

  • Options
    nick_papageorge073nick_papageorge073 Member, csevp Posts: 683 PRO
    edited April 14
    Why are you using those dxf imports for the text? Use the built-in text tool instead. Several fonts are available, and the modeling will be 10 times easier.



    CAD Link:
    https://cad.onshape.com/documents/ae2ed78acd67ba8e2ccec134/v/3d66e90c4c996e885b9a8f1a/e/fa31f8e4cf017140c93b8ceb?renderMode=0&uiState=661be4610a26f573f1444624
  • Options
    nick_papageorge073nick_papageorge073 Member, csevp Posts: 683 PRO
    edited April 14
    I checked your model, the root issue is the height of the 0 number is not high enough. Do a move face on it to make it taller, then the union will work.

    That said, I'm not sure what you are trying to do. The model is super super super complicated. dxf imports of text that is very jagged. Transforms all over the place. Extruding the same surfaces over and over. I'd start over completely and do it the way I did, using the built in text tool. There is no need for the transforms or the other stuff you have in your model.
  • Options
    brett_jones039brett_jones039 Member Posts: 4
    I checked your model, the root issue is the height of the 0 number is not high enough. Do a move face on it to make it taller, then the union will work.

    That said, I'm not sure what you are trying to do. The model is super super super complicated. dxf imports of text that is very jagged. Transforms all over the place. Extruding the same surfaces over and over. I'd start over completely and do it the way I did, using the built in text tool. There is no need for the transforms or the other stuff you have in your model.
    Hi Nick,

    Thanks for your replies. I have some plasma cut numbers that I am trying to insert into this part tightly, so I need the DXF imports (they are scans of the real-world pieces with all of their imperfections). I then needed to make the cutting tools slightly larger to add tolerance, so that's why there are all the extrude and thicken features (messy, I know).

    I don't know what "a move face" is, but I will research it and hopefully figure it out!
Sign In or Register to comment.