Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Options

Show sketch created with a feature in a drawing

I am able to show a sketch that I've created in a part studio in a drawing.
However, if I create a sketch using a feature, then that sketch isn't in the available list of sketches associated with a part studio. 
How can I insert a sketch that I create with a feature into a drawing?
Tagged:

Answers

  • Options
    tim_hess427tim_hess427 Member Posts: 648 ✭✭✭✭
    Are you using a custom feature? I can't think of any feature that create sketches inside the feature. 

    One workaround you could try is to manually create the sketch you want before you create the feature. Then, inside the feature, you can copy all the sketch elements into the feature sketch with "use".
  • Options
    mahirmahir Member, Developers Posts: 1,292 ✭✭✭✭✭
    Probably less complicated would be to do the opposite. After the custom featurescript, create a sketch that uses all the edges you want in the drawing. Then show that sketch in the drawing.
  • Options
    monroe_weber_shirkmonroe_weber_shirk Member Posts: 96 EDU
    Tim and Mahir, Thank you both! I am using a custom feature to create the sketch. I'm wondering what sketch property is being used by the drawing to query the sketches and exclude the sketches created by custom features. If I could figure that out I could change that property and then I'd have a robust solution.
  • Options
    monroe_weber_shirkmonroe_weber_shirk Member Posts: 96 EDU
    The "use" command seems to require selecting each sketch entity one by one. I'm creating a sketch with many parts (the reason I created it in featurescript) and it is configurable and the number of parts varies. 
Sign In or Register to comment.