Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:

  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

The Red

henry_feldmanhenry_feldman Member Posts: 112 EDU
So, a very frustrating thing in OnShape is "the red". And what do I mean by that? Well, that when you do some operation (in this example a sweep) that the title turning red indicates that something is wrong, but there is no message or other indicator to tell you what the issue is.

Well WTF is wrong? No option is red to indicate what the problem is. There is no error message anywhere on the screen, just the red title. So I have no idea what to correct here. I've done this identical operation to 3 other extruded pins and it all worked fine, but this one, red? See, if it told me (that pin can't be used because it is a sunday or whatever) I would know how to correct it...


Comments

  • _Ðave__Ðave_ Member, Developers Posts: 712 ✭✭✭✭
    Henry, Try holding your mouse over the red "sweep 3" until the error message appears.
  • henry_feldmanhenry_feldman Member Posts: 112 EDU
    _Dave_ said:
    Henry, Try holding your mouse over the red "sweep 3" until the error message appears.
    Genius! Thanks, I hadn't tried the obvious in hindsight thing, but not sure that's a normal UI thing. Of course if you were red-green colorblind you'd be screwed. It is weird that some errors produce a visible error message (the blue notification at the top) while others if you didn't know (which I didn't, thank you) to use the tool-tip to see an error message...
  • henry_feldmanhenry_feldman Member Posts: 112 EDU
    _Dave_ said:
    Henry, Try holding your mouse over the red "sweep 3" until the error message appears.
    @__Dave__ I will add that the majority of the messages are "The xxxx failed to generate". Duh, I can see that. Can you tell me why? They need better error messaging.
  • 3dcad3dcad Member, OS Professional, Mentor Posts: 2,387 PRO
    I would like to have a 'fix' -button for simple errors in a long haul..
    //rami
  • henry_feldmanhenry_feldman Member Posts: 112 EDU
    3dcad said:
    I would like to have a 'fix' -button for simple errors in a long haul..
    amen brother...
Sign In or Register to comment.