Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:

  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Has anyone else experienced missing files from STP assembly imports?

shawn_peteshawn_pete Member Posts: 3
edited March 2016 in Community Support
I have on two seperate occasions imported an assembly from Creo into OnShape as an STP file.  On both occasions the resulting OnShape assembly was missing a component.  The STP file opened correctly from within Creo so the component wasn't missing from the file.
Tagged:

Best Answer

  • shawn_peteshawn_pete Posts: 3
    Accepted Answer
    I tried uploading one of the offending files to individually to OnShape and received a translation failed message.  I then submitted a ticket to support attaching the STP file.  Turns out there was an error with a surface that was preventing OnShape from translating it.  The support rep fixed the issue and sent me a healed STP file.
    What I don't understand is why it happened in the first place.  My desktop software was able to open the STP file (assembly and individual part) without issue.  None of the other assembly components were affected.

Answers

  • viruviru Member, Developers Posts: 619 ✭✭✭✭
    @shawn_pete ,May be it is happening due to performance issue of your internet speed. If it is happening same  in stable internet speed then best way to address such issues by sending the ticket using feedback tool as given below to Onshape support team.



    It will also allow you to share your document with Onshape support team as below.



    You will get notification mail from Onshape immediately with ticket details and status.



  • jakeramsleyjakeramsley Member, Moderator, Onshape Employees, Developers Posts: 602
    Can you double check that the missing parts are indeed parts, and not surfaces?  I have a couple x_t files that import some surfaces which can't appear in assemblies currently which I need to be reminded of.

    Each part and surface should have a corresponding part studio, so would be interested to see if there are any surfaces in it.  If not the best thing you can do for us to fix it is to share the document and step file with support (if you are willing).
    Jake Ramsley

    Director of Quality Engineering & Release Manager              onshape.com
  • derek_wardderek_ward Member Posts: 58 EDU
    I haven't experienced this issue with STP files yet, but I have experienced it with importing SolidWorks Ready-To-Go assemblies.  I currently have an open ticket and will let you know if anything happens. 
  • shawn_peteshawn_pete Member Posts: 3
    Accepted Answer
    I tried uploading one of the offending files to individually to OnShape and received a translation failed message.  I then submitted a ticket to support attaching the STP file.  Turns out there was an error with a surface that was preventing OnShape from translating it.  The support rep fixed the issue and sent me a healed STP file.
    What I don't understand is why it happened in the first place.  My desktop software was able to open the STP file (assembly and individual part) without issue.  None of the other assembly components were affected.
Sign In or Register to comment.