Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:

  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Space Navigator by 3DConnexion Loses Rotation

nik_willmorenik_willmore Member Posts: 33 ✭✭
edited October 10 in General
A few times a day when I'm using free time to learn Onshape, I go back to Onshape from being in other browser tabs and working in Rhino, the Space Navigator loses rotation ability and all I can do is zoom. It has done this over the last year several times a day in various browsers, first Chrome, then Vasari, and lately Opera. I switched to Opera eventually for less lag. Then I got a brand new low profile NVIDIA Quadro card instead of using motherboard video and that certainly helped but not for the Space Navigator fall out that requires me to quite the whole browser and stop then restart my 3DConnection driver then restart the browser and usually Onshape comes up again with the same live model I can again start rotating. There is a bit of slow response in general from the Space Navigator still but much better with a real graphics card.

Is there a service I can quick restart instead to avoid quitting the browser and cycling my driver?

When in this dysfunctional state, the 3DConnextion control panel shows it connected to Opera instead of Onshape like usual. Lately when it's working the 3DConnextion Properties panel sometimes lists StartMenuExperienceHost but usually just Onshape.

Comments

  • TimRiceTimRice Member, Moderator, Onshape Employees Posts: 224
    @Nuno ; will know more but in general you can search for the 3DxNLServer application and restart it when your device loses connection. Then, back in Onshape, clear your browser cache by holding shift while refreshing the page (In Chrome and Firefox, not sure about Opera).

    Also, I assume you are using Windows? Or macOS?
    Tim Rice | User Experience | Support 
    Onshape, Inc.
  • nik_willmorenik_willmore Member Posts: 33 ✭✭
    edited October 10
    Good to know a background app by name, thanks.

    Windows 10.

    Just updated 3DConnextion driver from 9/25/2019 but the last few updates didn't help so who knows?

    Ah! The reason I can only zoom is that the Space Navigator is set to merely scroll within Opera as a browser, so I'm not just losing my rotation by my whole connection to Onshape while the Space Navigator starts issuing a thumbwheel scroll that makes Onshape zoom. That's a simpler dilemma to explain. 

    With the 9/25 driver update, rather bizarrely, the Navigator response is perfectly fast now. 

    I had 3DConnexion set to look for updates automatically but it never suggested this latest one so I've been on the former version.
  • nik_willmorenik_willmore Member Posts: 33 ✭✭
    edited October 11
    Well, now that it happened again, I see that the server in C:\Program Files (x86)\3Dconnexion\3DxWare\3DxNLServer\bin isn't running at all:

    So if I manually double click it, to start it, then reload an Onshape model (without any cache clearing modifier key), it starts working in Onshape again.

    So 3dxnlserver.exe is crashing on the latest versions of Windows 10 with a wired Space Navigator, actually Bluetooth but used with a cable.

    Now I have the server pinned to my taskbar, via right clicking it in its Windows 10 directory, so I can restart it easily.

    What is interesting from the Onshape side is that I must reload each Onshape model browser tab. So I can have it working on one Onshape model but not the other, in the same Opera browser session.
  • Rickey_WangRickey_Wang Member Posts: 1 PRO
    I had major struggles with the 3DxNIServer. Here are the instructions from the 3DConnexion team that helped me resolve the issue, now I only need to restart it rarely instead of a few times an hour.

    1. Uninstall the driver through the windows uninstaller (where you would go to install/uninstall programs).

    2. Navigate to %APPDATA% (e.g. C:\Users\USERNAME\AppData\Roaming\) and rename the folder '3Dconnexion' to '3Dconnexion.bak'.

    3. Navigate to %LOCALAPPDATA% (e.g. C:\Users\USERNAME\AppData\Local\) and rename the folder '3Dconnexion' to '3Dconnexion.bak'.

    Before proceeding with the next steps, it is strongly recommended that a backup of the registry be made. Instructions how to backup the registry can be found on Microsoft's website: https://support.microsoft.com/en-us/help/322756/how-to-back-up-and-restore-the-registry-in-windows.

    4. Click the 'Start' button and 'Run' type in 'regedit' and hit OK to bring up the Registry Editor. There is a registry entry under the branch HKEY_CURRENT_USER under the 'Software' folder. Rename the '3Dconnexion' folder found in this location to '3Dconnexion.bak'.

    5. Reboot the computer.

    6. Reinstall the driver and test for issue.

  • nik_willmorenik_willmore Member Posts: 33 ✭✭
    It was exceedingly difficult to tweak my Windows 10 permissions and ownership to be able to delete the AppData\Local directory, which may explain why the normal 3DConnexion driver updates were leaving behind old crap.

    Bad permissions may be what was causing the whole problem.
Sign In or Register to comment.