Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Threads not being generated

ihor_gernagaihor_gernaga Member Posts: 24 PRO
I'm attempting to create in internal thread to an imported part and I keep getting an error message that saids "boolean operation failed to return a valid part". I created an external thread and that worked on a new part. I've tried removing and adding material, as well as tweeking the sweep face with no avail. Your suggestions would be appreciated. Thanks.

Comments

  • bradley_saulnbradley_sauln Moderator, Onshape Employees, Developers Posts: 351
    I would suggest creating a support ticket and sharing the document with support. Without seeing the document it may have something to do with the imported part. Is the import being seen as a solid component? Also might be good to do a quick check on the scaling of things as that gets me every once in a while.
    Engineer | Adventurer | Tinkerer
    Twitter: @bradleysauln


  • ihor_gernagaihor_gernaga Member Posts: 24 PRO
    I adjusted my pitch and that fixed it. I was over complicating the solution. Just needed a fresh perspective.Thanks. 
Sign In or Register to comment.