Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Importing files

john_brodowskijohn_brodowski Member Posts: 37
I have no problem modeling parts. I have discovered some important OnShape modeling issues, but maybe they will be resolved in the future.
File navigating I find cumbersome .I am used to Pro-e.
Here is one more item I have problem with-importing files.
Here are the steps I have taken trying to import STP to OnShape Document and open it.
1-Found commercial  STP file for an item I wanted to import and saved it in my laptop Download directory.
2- Went to Import  OnShape icon and clicked it.
3-OnShape Import showed my computer directories among which was Download directory
4-I found downloaded STP file in the Download directory and opened it.
5-Went back to OnShape and there it was listed in my Documents.
6-There is no way I could open it. No preview available, I am told.


  • _Ðave__Ðave_ Member, Developers Posts: 712 ✭✭✭✭
    It should have imported into aa part studio within that document. I'd suggest raising a ticket to Onshape using feedback from the ? in the upper right of Onshape ( not this forum). They usually reply promptly.
  • shashank_aaryashashank_aarya Member Posts: 265 ✭✭✭
    edited September 2015
    @john_brodowski I guess you are able to open that STP file in ProE but not in Onshape. I have found some information from Creo (formerly known as ProE). There are several step export format in Creo as shown in below picture highlighted in red. 

    I exported the part from Creo in all above step formats and they can be opened through Onshape. Since I am using Creo I know only above formats. Other tools such as NX and CATIA may have other formats to export also. You can check the format of source file which do not support Onshape and raise the ticket accordingly.

  • andrew_troupandrew_troup Member, Mentor Posts: 1,584 ✭✭✭✭✭
    There may be a problem with the file you're trying to import, but it's hard to tell from your description.

    I suggest going through the procedure detailed at
    Since it seems you have already tried the first method, I suggest trying the second, starting with the words 
    "Importing from within a document".

    This requires creating a document first.

    When you click "Import" from within that document and select your file as directed in the Help writeup, you should be presented with the "Import Processing Options" dialog shown further up, under "Processing CAD Files"

    IF this dialog does not show (under either this method or the other method you already tried) that suggests there is a problem with the file format, or with the file, or a bug in the Onshape Translator. 

    If you have reason to suspect the latter (ie the file is a valid format for Onshape to import, and especially if it imports OK into another CAD package) then please click on the ? icon at top right and choose "Feedback", and raise a ticket describing the problem.
Sign In or Register to comment.