Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Unable to add featurescripts, gets stuck on loading with spinning wheel

ryan_mcgoldrick47ryan_mcgoldrick47 Member Posts: 93 ✭✭✭
Unable to add featurescripts, gets stuck on loading with spinning wheel

For some reason I seem to be unable to add in featurescripts right now such as
https://cad.onshape.com/documents/25a0a6dfaa76e64574a5e0db/w/ed2afaf5bd2d12066495dc84/e/4c62c06c4e0e4db3703a2d4c
https://cad.onshape.com/documents/9fca78cb66a0bc83e359eb3e/w/01ed403357f48b8904c9b631/e/7052b96c07018ad97bbadbf9

It just spins saying "loading custom features and tables"

Comments

  • MichaelPascoeMichaelPascoe Member Posts: 929 PRO
    I had this problem too. For me, it was related to my browser, Brave. I temporarily switched to Firefox and it loaded normally.
  • mike_paulonismike_paulonis Member Posts: 2 EDU
    I'm having this problem as well with 

    https://cad.onshape.com/documents/c54b1ff25af8ec89778cac4f/w/ace59da8ae4ae6dd11eabd2a/e/c4fc9251685f8516e9022bc6

    I've tried using Chrome, Firefox, and Edge browsers and all I get is the spinning wheel with "Loading custom features and tables...".

    I tried turning off browser extensions in Chrome and Firefox.  I never use the Edge browser, so it is in an unmodified, as-installed state.

    I noticed the problem when trying to get the above Featurescript.  However, I've tried getting others and the problem appears to apply to all Featurescripts for me, not just the one behind the link.  I have successfully installed many Featurescripts in the past, so this problem is new.

    Any other ideas on how to solve the problem besides switching browsers?
  • MichaelPascoeMichaelPascoe Member Posts: 929 PRO
    @mike_paulonis hm, I'm out of ideas on this one. You may have to start a support ticket. They usually respond within an hour.
  • lanalana Onshape Employees Posts: 664
    This is a known, though hard to chaise, bug. Please use following work-around for now. After you've opened the Feature Script document in any part studio you have edit permits for you can Add it to the toolbar with this button, The containing document will be among recently opened.
  • ryan_mcgoldrick47ryan_mcgoldrick47 Member Posts: 93 ✭✭✭
    Thanks Lana, saved that for future reference.
  • mike_paulonismike_paulonis Member Posts: 2 EDU
    I looked back into this a week later, thinking I should probably engage support.  The Featurescript install just worked this time using the first browser I tried, which was Chrome.  It took several seconds for "Loading custom features and tables" to stop spinning and bring up the plus icon to install, but some amount of delay in getting the plus icon is typical for me.  I don't know what was wrong before or is right now.  If I have problems in the future, I will probably go straight to support.
  • robert_scott_jr_robert_scott_jr_ Member Posts: 105 ✭✭
    I also have experienced this issue. Rebooting restored the function. - Scotty
Sign In or Register to comment.