Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Feature script "Beam" - feature library update

frank_ringfrank_ring Member Posts: 32 ✭✭
Since today I get this messge when using feature script "Beam" (graphic is in german):
"This workspace uses an old version of the feature library and must be updated before the Beam feature can be used".
A new Version for "Beam" is currently not available?
Thanks for your help.
Frank



Best Answer

Answers

  • frank_ringfrank_ring Member Posts: 32 ✭✭
    In the meantime, I have made the following discoveries:
    After the security update from this morning (Windows 11 + Edge Browser) the described message appears.
    On a machine with Windows 10 + Edge, everything seems to work normally. The problem seems to be with Windows 11.
    Does anyone have any ideas?
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 4,308
    edited February 9
    It has nothing to do with your computer. How old is the document? If it is older than the last time the Beams feature was updated (Official V28, Nov 2021) and the document was somehow not upgraded, then that will be the reason. Quick fix is to use an older version of Beams. Other fix is to report a bug (from the help menu).
    Director, Technical Services, EMEAI
  • frank_ringfrank_ring Member Posts: 32 ✭✭
    The error even appears when creating a new beam. This document is only a few days old.


  • dirk_van_der_vaartdirk_van_der_vaart Member Posts: 268 ✭✭✭
    Just update the Beam feature, right click on the icon.
    Version should be original V28
  • frank_ringfrank_ring Member Posts: 32 ✭✭
    The installed version schould be the newest. There is no update available.


  • romeograhamromeograham Member, Simulation EVP Posts: 609 PRO
    Answer ✓
    @frank_ring
    It looks like you're not using the Official Beams featurescript - but someone's copy.
    @NeilCooke above referenced the Official one is at V28.


    You can install it from here: https://jps.onshape.com/documents/e15c2c668d138f01242d0c80/v/346d15aa4aa231b970b2fa9a/e/2d5660fc1012df9598f00251
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 4,308
    Director, Technical Services, EMEAI
  • frank_ringfrank_ring Member Posts: 32 ✭✭
    Ok. It works again. Sorry for the misunderstanding. I didn't realize that I didn't copy the original branch.
    Thanks for your help  :)
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 4,308
    Ok. It works again. Sorry for the misunderstanding. I didn't realize that I didn't copy the original branch.
    Thanks for your help  :)
    Make sure you are not copying the Beams document, but simply adding it to your toolbar, then you'll get notified of any updates.
    Director, Technical Services, EMEAI
Sign In or Register to comment.