Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Fillet misbehavior

joseph_newcomerjoseph_newcomer Member Posts: 70 ✭✭
edited June 5 in Community Support
I did a sketch with a complex filleting.  It got into a state where I kept getting the error message that it could not do the fillet.  But it did not highlight the fillet it could not do.  I kept removing fillets and the message did not go away.  I could not add anything because every time I tried to add something I got the error message, and whatever I had just tried to do had no effect.  Finally, I was left with some lines and a couple little circles that might have been the centers of fillet radii, but they could not be deleted.  Each time I tried to select one, the error message would pop up, and when I released the mouse button, the little circle was deselected and I couldn't delete it at all.  Ultimately, I deleted the sketch entirely and started over, doing something much simpler.

Now I have another problem: I cannot fillet the element it will clip to.  I select the edges, but it won't fillet, and says that the reason is that I have not selected the edges.
 

In the model I have given the link to, you can see the (red) clip that is going to clip onto the (blue) element (the clip grooves are not there yet).  I want to fillet the slot into which it will fit.  I have tried to select edges, and have tried both edge and full-round filleting.  Nothing works.

Here's a screen shot.  Note that I have clicked in the "Entities to fillet", selected the two edges, and neither of them appear in the list.  The width is #sep_thickeness/2; #sep_thickness is the thickness of the blue element.


To add to the weirdness, when I re-created what is called Sketch 3, I was getting errors about not being able to create a fillet, even though I had done nothing to create a fillet in the new drawing.  So there is something deep going on here, but I don't know what.

UPDATE: I decided to add the grooves for the clip.  I created what is called Sketch 4 (I have not yet given them sensible names).  Partway through, I created the triangle (I had not yet sized it), but as you can see on the image below, the fillet error message  popped up, although the only two entities in the sketch is the line that places the endpoint to which I would fasten the triangle, and the triangle itself.  There is not a fillet anywhere in the sketch.  Essentially, I drew the construction line, attached it to the top corner of the slot, put the dimension (#clip_height) onto it, created the triangle, put a vertical constraint on the edge, and there was the fillet error message!

Tagged:

Best Answer

Answers

  • steve_shubinsteve_shubin Member Posts: 885 ✭✭✭✭
    Answer ✓
    @joseph_newcomer

    Give this a try 




  • joseph_newcomerjoseph_newcomer Member Posts: 70 ✭✭
    That worked, thank you.  I don't know why it came up on "width"
  • S1monS1mon Member Posts: 1,057 PRO
    Onshape remembers the last setting of selections like that. You must have used a "width" fillet recently.
Sign In or Register to comment.