Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Some Imported Parts Partially Colored, Edit Appearance No Effect

ben_harkinben_harkin Member Posts: 8
I'm importing some STEP files and have found that some parts are partially another color than that in "Edit Appearance" and that changing edit appearance has no effect on the color. In the features list, "Import" is not red.

The entire part should be green. Document link

Best Answers

  • wayne_sauderwayne_sauder Member, Simulation EVP Posts: 300 PRO
    edited July 13 Answer ✓
    @ben_harkin
    I don't understand why this is happening for sure, however, as a workaround, you can box select then RMB and apply an appearance to all faces. 
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 4,508
    Answer ✓
    It's not a bug, it is working as intended. The faces have assigned colours in the STEP file and Onshape is honouring them, however there is a technical reason (which I can't remember what it is) that prevents us from displaying them in the appearance panel.
    Director, Technical Services, EMEA

Answers

  • wayne_sauderwayne_sauder Member, Simulation EVP Posts: 300 PRO
    edited July 13 Answer ✓
    @ben_harkin
    I don't understand why this is happening for sure, however, as a workaround, you can box select then RMB and apply an appearance to all faces. 
  • ben_harkinben_harkin Member Posts: 8
    Thanks, that works. However it does seem like a kind of bug.
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 4,508
    Answer ✓
    It's not a bug, it is working as intended. The faces have assigned colours in the STEP file and Onshape is honouring them, however there is a technical reason (which I can't remember what it is) that prevents us from displaying them in the appearance panel.
    Director, Technical Services, EMEA
  • lukas_szwugierlukas_szwugier Member Posts: 3 PRO
    If you need to add appearance to import, and you need one color for it, you may add appearance to feature.
    It will change color for complete import. :)
Sign In or Register to comment.