Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Can't scale a part on the Z axis

peta_labpeta_lab Member Posts: 7
edited March 9 in Community Support
Hello, I'm pretty new to OnShape as a whole, but I've spent some months trying to get the basics down to a point where I feel I'm somewhat confident with the program. That being said, I just found a very weird constraint that doesn't allow me to continue with a project I'm currently working on. The issue went as follows:

  1. I downloaded several STL files and imported them as parts in separate Part Studios, but all gathered in the same project, as each STL needed to be "cleaned up" and then saved as a composite part (by "cleaning up" I mean taking a full body model of a character and turning it into a bust using several methods).
  2. I saved each character model as different composite parts and then gathered them all in a new Part Studio to figure out some proportions I needed for additional parts.
  3. I tried to resize all composite parts to 2.75 times their original size, but it wouldn't let me.
  4. I tried going through each composite part individually and discovered that the only one that wouldn't be resized was one in particular.
  5. I went back to that composite part's studio and tried to scale it up from there, to no avail.
  6. I divided the composite part and tried to scale up each individual surface and part, until I found out that the culprit was a single surface that wouldn't scale up to anything over 2 times its original size.
  7. I tried scaling said surface up in the X, Y and Z axis separatedly and found out that the only axis that didn't allow resizing properly was the Z one.
  8. I moved the part around and tried again, to no avail.
  9. I came here looking for answers.
This has me genuinely confused, I have no idea how such thing could happen. I do remember importing the original STL model in meters by mistake and working on it until I realized that I needed it to be in millimeters. Once I noticed that midway through the "cleaning" process, I scaled everything down and kept going. The thumbnail image for that particular part seems to be acting weird, as if I had left out something after the first downscaling, since it shows the composite part from very, VERY far away (I assume it's trying to fit everything into frame). However, I inspected the document carefully and couldn't find whatever laid way up above the composite part itself.

I guess my best hypothesis now is that the surface I'm trying to upscale now is somehow linked to another surface of ridiculously small size that's floating above it, and so every time I try to upscale it past twice its original size it might force OnShape's 3D rendering program to overflow, which in turn prevents me from completing the upscaling. Any and all tips would be greatly appreciated, as I don't want so many hours of work to go to waste (or to re-do them for that matter).

EDIT: I gave up in the end and decided to re-do the cleanup process for that specific model, which allowed me to optimize it a bit more. Guess the reason behind this weird error will remain a mystery...


  • S1monS1mon Member Posts: 1,986 PRO
    Most likely this is going to be dependent on the geometry of the STL files in question. If you can share a public link, or perhaps contact support…
Sign In or Register to comment.