Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Options

how to use a variable to set a size and why does # mess up my view instead?

mark_nahabedianmark_nahabedian Member Posts: 31
edited March 2023 in General
I have a variable whose value is the diameter of a 1/4-20 washer.  I'm trying to place a circle in a sketch. I want its diameter to be set from that variable.  When I try to type the variable though, OnShape interprets the # as "please mess up my view".  

Also, I can't find how to turn lines into guides anymore.

Thanks.


Comments

  • Options
    _anton_anton Member, Onshape Employees Posts: 301
    Could you clarify what you mean by "mess up my view"? We can help if you share a screenshot (or, better, the document).
  • Options
    S1monS1mon Member Posts: 2,450 PRO
    Unlike regular dimensions which you can just start to type, you need to click the dimension first if you want a variable. That's because shift-3 ("#") is also a keyboard shortcut for left view.
  • Options
    mark_nahabedianmark_nahabedian Member Posts: 31
    Is there a way to disable that screen short cut?
  • Options
    mark_nahabedianmark_nahabedian Member Posts: 31
    Also, when I'm editing a sketch, why would I ever want a view that isn't diirectly "above" the sketch plane?
  • Options
    mahirmahir Member, Developers Posts: 1,292 ✭✭✭✭✭
    edited March 2023
    @mark_nahabedian I think I understand. Shift+3 is the shortcut for left view. It's also how you would type "#". However, when you're editing a dimension (probably just after you create it) the view shortcut should not engage. Are you just selecting the dimension instead of double clicking to edit?

    Also FYI you can get back to a normal sketch view by clicking N.
  • Options
    S1monS1mon Member Posts: 2,450 PRO
    There's currently no way to disable shortcuts.

    I want to view things in 3D a lot when I'm sketching. If you want to "use edge" or align a line or vertex to specific features, it's often the case that you need to see exactly what you're selecting.
  • Options
    mark_nahabedianmark_nahabedian Member Posts: 31
    If I try to click on the circle's dimension box right after I've dragged the radius, it starts drawing another circle.

    If I escape, click on my original circle and then try to edit its diameter in the lower right by first clicking on the dimension, # still changes the view.
  • Options
    S1monS1mon Member Posts: 2,450 PRO
    Sorry. You can start to type a number and then hit backspace and then type #. 

    I hardly ever type in the dimensions as I'm sketching. I usually sketch a bunch of stuff and then dimension afterwards. If you add dimensions afterwards, then you don't have the same issue with hitting shift-3 triggering the view.

    I really should get more in the habit with dimensioning as I go (where it makes sense), but typically the dimensioning scheme I want to use is not going to be auto generated.
  • Options
    mark_nahabedianmark_nahabedian Member Posts: 31
    Got it.  Thanks uch.

    I remembered that there was a trick to it, but couldn't remember what the trick was.
Sign In or Register to comment.