Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Options

Onshape filling in spaces where I want nothing?

oliver_cheatham543oliver_cheatham543 Member Posts: 2
Hey folks, new to Onshape (and CAD in general) and trying to use it for a school project. The problem I'm having definitely has an easy fix, just one I can't seem to find. When I connect four rectangles, It automatically fills in the space inside the shape as a new object where I want nothing to be. The image I'm attaching is just four 1x4 rectangles, but because they're connected Onshape has created an additional square to fill the gap. How do I get rid of it, or stop this from happening? Much appreciated :smile:

Basic Example:



And then the application it has on my first project:

Comments

  • Options
    robert_scott_jr_robert_scott_jr_ Member Posts: 392 ✭✭✭
    Hello Oliver. The greyed areas represent an area that is completely enclosed. This is desirable in most, perhaps all cases because it is required when using the 3D tools that are found on the left of the toolbar next to the sketch icon. If it is not wanted to be used in a feature, such as an extrude, simply don't select that area. - Scotty
Sign In or Register to comment.