Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Options

Extreme performance issues in complex sheet metal part

tilman_guenthertilman_guenther Member Posts: 2
I am building a lamp for my living room, and am having extreme performance issues. Even outside of parametric changes, every single action in the Parts Studio takes upwards of 5 seconds. This includes creating new sketches, drawing lines, swiching to dimension tool, etc. On more "complex" operations, like performing an extrude or fillet, I often have to wait 30 seconds or more before it does anything, and wait again for each selection. It always spends quite a bit of time on "Preparing <feature>".

Here is a link to the current design, it's the "Version 2" Parts Studio.

I'm not sure what the issue is... while the sheet metal stuff seemingly takes a long time to regenerate, even when the sheet metal components are no longer "active" and have been "Finished" doing anything takes forever. Nothing in my timeline is especially egregious (no derive chains) and the biggest regeneration-time eater is apparently a "move face" command which takes like 5s. 

Any help or support would be greatly appreceated. Is this me/can I do something better to make it go faster, or is this just a limitation in the software?

Thanks

Comments

  • Options
    S1monS1mon Member Posts: 2,557 PRO
    The link seems to be missing. 
Sign In or Register to comment.