Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Mismatch of system Axis

heiko_presselheiko_pressel Member Posts: 9
edited April 2016 in Community Support
Hi everybody,
I need your Help!
For some unknown reason the Axis of the System and the axis of the triad manipulator of the Assembly don't match.
Can anyone tell me what i did i do wrong and how can i realign them?

Thank you


Best Answer

Answers

  • Narayan_KNarayan_K Member Posts: 379 ✭✭✭
    edited April 2016
    @ heiko_pressel ,arrows of triad manipulator indicates the axis of part in part studio. Once you insert part from part studio by default it will align to the axis of assembly studio. after constraining it mismatch with axis of assembly.


    You can match it by rotating the part as below.

  • kevin_o_toole_1kevin_o_toole_1 Onshape Employees, Developers, HDM Posts: 504
    To get the axes aligned precisely, you can also make a fastened mate to the assembly's origin:



  • heiko_presselheiko_pressel Member Posts: 9
    Hi Narayan

    Thanks for your answer, but the problem not solved yet.
    I cannot rotate. The triad manpulator snaps back to its former position after releasing the mouse button and it does not take the assembly with it, as it does on your (very nice) example.
    Even if it would, how could i allign it "perfekt" with the system Axis, so it shows in line perfekt in the end on the drawing?
    If i try to allign with the triad manipulator with the Z axis by a right mouse click it gives me

    "unable to apply transform,
    instance(s) may be constrained" ??

    There has to be a kind of bug, sometimes Onshape lets me move the assembly by left mouse klick, and suddenly it only is possible by klicking the mouse wheel???

    That sucks!!

    Thanx
    Heiko
  • heiko_presselheiko_pressel Member Posts: 9
     to Kevin,

    now i got the triad manipulator alligned with the system axis but the whole dammed assembly stands square??

    I would like it all to be alligned.
    and i would like to "move it, move it" ;-))


  • viruviru Member, Developers Posts: 619 ✭✭✭✭
    @heiko_pressel, I think you are moving origin and user cannot move origin. User can move part with the help of triad manipulator. For getting your requirement you have to refer below method.
    1) First you have to give mate relationship with respect to each part. If you did not want to give each constraint initially then select each parts and give group constraint.
    2) Now select fastened mate constraint and select mate connector of part and mate connector of origin.
    Kindly refer below video which may be helpful to solve your problem.





  • heiko_presselheiko_pressel Member Posts: 9
    Hello Viru

    thank you very much for your assistance.
    I tried your solution with a example and it worked perfekt.

    But!
    I'm coming closer but it still dosen't work.
    With the Help of your tutorial i found out that the assembly has a fix (ed?) relation to the origin. Thats the reason why the object allways snaps back when i'm using the triad manipulator. Orientation as well as position to origin. For that reason it also is not possible to realign the assembly with the systems axis system.
    I checked all parts and subassemlies but cannot find why the assembly is fixed to the origin.
    I also found out that i can move Assemblies, that are not fixed to the origin, with the left mouse button but assemblies fixed to the origin can be moved only with a clic on the mouse wheel. for that reason suddenly while working the movement of the assembly by left mouse clic is disabled. That's when the Assembly get's (i don't know why) fixed to origin.

    Still hoping to solve it;-)
  • viruviru Member, Developers Posts: 619 ✭✭✭✭
    edited April 2016
    @heiko_pressel,There will be chances that you had given fixed relationship to any part in your assembly that may be reason for not moving. kindly check and make unfix.

    Can you share your document with us then we can go in detail and find solution for you.




  • heiko_presselheiko_pressel Member Posts: 9
    edited April 2016
    @Viru & Forum,

    Thanx for your assistance.
    I checked and didn't find a fixed objekt in my construction.

    I published the whole work under "Vierkantstahl Cubus"

    https://cad.onshape.com/documents/40986132b08c47a7952f508d/w/5c9561b8296a4ed5bd03c3e6

    The assembly that causes problems is "Ass Zus Bau Kpl"
    You should be able to open the Problem ;-))

    Ill be happy for any further idea.

    Heiko

  • heiko_presselheiko_pressel Member Posts: 9
    @Viru and the whole Forum,

    THAT'S IT!!

    Thanx a lot. I was not careful enough!
    Great and very patient help!
    Nice not to laugh out loud. It's kind of embarrassing anyhow.
    I'm glad i can work on now.
    Great community. :)

    Once again, thank you for the Help.
Sign In or Register to comment.