Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Will there be support for a space mouse?

2»

Answers

  • chrisjh777chrisjh777 Member Posts: 198 ✭✭✭
    @chrisjh777,

    Can you try closing out your browser and re-opening it?  In my experience the jerky navigation meant the driver couldn't find focus on the client and needed to be reset.  The other thing I try is to stop the driver and then start the driver again.
    OK,  

    I tried opening and closing my Chrome Browser, Rebooting the computer, stopping and staring the driver, and a total reinstall of the driver.

    All to no avail.  Still works fine in Solidworks.

    Take 2:  I decided to ignore the fact that my 3DConnexion Mouse had stopped working as I first witnessed and continued working on with a design.  As soon as I added a new part studio, the bloody mouse started working again and has been working all day.  Don't know why starting a new part studio caused the mouse to leap into action, but so far so good.

  • imagineeredimagineered Member Posts: 57 ✭✭
    @chrisjh777 - I too have the same problem - zoom only & very slow & jumpy.

  • richard_charneyrichard_charney Member Posts: 2
    I'm having the same issue. I can only zoom in and out. Very herky jerky and no rotation.
  • lougallolougallo Member, Moderator, Onshape Employees, Developers Posts: 1,995
    Firefox has been giving some intermittent issues but Chrome should work.  If you have having issues try to do a SHIFT reload (which rebuild the client cache.)  This has been able to get some of them working.  The other thing to check is the driver itself.  If you are unable to get it working, please contact 3Dconnexion support if it appears to be driver related.  I have had a few tell me to remove and install the 10.2.8 driver. 
    Lou Gallo / PD/UX - Support - Community / Onshape, Inc.
  • richard_charneyrichard_charney Member Posts: 2
    SHIFT reload???
  • jakeramsleyjakeramsley Member, Moderator, Onshape Employees, Developers Posts: 643
    SHIFT reload???
    Hold the shift button down and click on the reload icon.
    Jake Ramsley

    Director of Quality Engineering & Release Manager              onshape.com
  • simon_9simon_9 Member Posts: 17
    SHIFT reload???
    Hold the shift button down and click on the reload icon.
    For the record, I have just tried this to no effect.
    My problem seems to be related to the install and I have raised a ticket with 3D who are looking at the problem (I hope!)
    Simon
  • chrisjh777chrisjh777 Member Posts: 198 ✭✭✭
    OK,  Having been dealing with this problem for about a week now, I have observed that the behaviour is intermittent.  Some days it works fine and other days (like today), all it does is jerky zoom only (no rotation).
  • imagineeredimagineered Member Posts: 57 ✭✭
    @lougallo I have contacted 3D Connexion on the recommendation of OnShape. They are apparently looking into it. I had installed driver 10.2.8 but only Zoom worked. Now this morning without changing any more drivers or updating, it works. As @chrisjh777 has said it is fine some days & not others.  This would suggest the issue may be with OnShape or possibly bandwidth.  If internet speed is not available at the time, functionality may be reduced?
  • chrisjh777chrisjh777 Member Posts: 198 ✭✭✭
    Hi,  This morning (24 hours later) it is working again!!
  • michael3424michael3424 Member Posts: 623 ✭✭✭
    My Space Pilot Pro has also been working intermittently.  It seems to work after a computer restart (Win 7) and then at some later point stops working, even without much computer use.  Shift-Reload worked today but doesn't always.

    I'll follow up with 3D Connexion but wanted to add my experience to the discussion.
  • simon_9simon_9 Member Posts: 17
    As a matter of interest for those that have some use from their mice, if you right click on the tiny 3D icon at the lower right side of the toolbar and select 'open 3Dconnexion properties', does it pop up with a header for Firefox (or your own browser) or does it show OnShape?

    Simon
  • 3dcad3dcad Member, OS Professional, Mentor Posts: 2,466 PRO
    @simon_9  The 3dconnexion driver is for windows. The program you are executing is firefox (or other browser). The page you are visiting is Onshape (code runs in your browser).
    Setting are made for windows programs and Onshape is not a windows program so it will show settings for your browser instead.

    This is one of the reasons I have dedicated chrome for onshape and use firefox for other browsing.
    //rami
  • simon_9simon_9 Member Posts: 17


    3dcad said:
    @simon_9  The 3dconnexion driver is for windows. The program you are executing is firefox (or other browser). The page you are visiting is Onshape (code runs in your browser).
    Setting are made for windows programs and Onshape is not a windows program so it will show settings for your browser instead.

    Hi Rami,
    Maybe I didn't explain myself clearly but 3Dc has different .xml setups for a number of applications including OnShape. In my case, 3Dc was clearly not identifying that it was talking to OnShape but understood it to be the simple Firefox browser instead. Having now achieved operation with a combination of Firefox and 3Dconnexion, I can see that 3Dconnexion recognises the OnShape add-in as shown in the screenshot.



    For those that are having trouble making the 3Dconnexion Navigators work (meaning anything more than zoom functionality), my solution was to go to Firefox's 'Add-Ons' page followed by selecting 'Plug-Ins' which revealed a problem with ShockWave Flash which apparently had a security problem (v16 or v17 I think). Selecting 'update' from within Firefox followed by a restart of the browser has instantly cured the problem. 
    No promises, but maybe it will work for you!
    Regards,
    Simon
  • jesper_frommherzjesper_frommherz Member Posts: 8 PRO
    My Space Pilot Pro quits working (not only in Onshape but systemwide) after switching from a part studio to a drawing.
    When i switch back to the part studio (tab) i can't control the view with my space pilot pro anymore.

    After that you either have to reboot the whole system or, as a workaround, close the browser, kill the process ”3DxNLServer” (via Activity app / macOS) and restart the server with the terminal:
    open /Library/PreferencePanes/3Dconnexion.prefPane/Contents/Resources/3DxNLServer.app
    Now the 3D Mouse works fine until i switch to a drawing and back to the part studio.

    Hopefully someone ca fix this?

    My system:
    Mac Pro late 2013
    3,5 GHz 6-Core Intel Xeon E5
    32 GB 1866 MHz DDR3
    AMD FirePro D700 6144 MB
    running macOS Sierra / 10.12.3

    Safari Version 10.0.3 (12602.4.8)

    3DConnexion Space Pilot Pro
    Dipl.-Des. Jesper Frommherz
    Bremen, Germany
    betonbank.de | apfeltalk.de

  • joseph_terpendjoseph_terpend Member Posts: 17
    simon_9 said:


    3dcad said:
    @simon_9  The 3dconnexion driver is for windows. The program you are executing is firefox (or other browser). The page you are visiting is Onshape (code runs in your browser).
    Setting are made for windows programs and Onshape is not a windows program so it will show settings for your browser instead.

    Hi Rami,
    Maybe I didn't explain myself clearly but 3Dc has different .xml setups for a number of applications including OnShape. In my case, 3Dc was clearly not identifying that it was talking to OnShape but understood it to be the simple Firefox browser instead. Having now achieved operation with a combination of Firefox and 3Dconnexion, I can see that 3Dconnexion recognises the OnShape add-in as shown in the screenshot.



    For those that are having trouble making the 3Dconnexion Navigators work (meaning anything more than zoom functionality), my solution was to go to Firefox's 'Add-Ons' page followed by selecting 'Plug-Ins' which revealed a problem with ShockWave Flash which apparently had a security problem (v16 or v17 I think). Selecting 'update' from within Firefox followed by a restart of the browser has instantly cured the problem. 
    No promises, but maybe it will work for you!
    Regards,
    Simon
    I am using Chrome and my Space navigator was working perfectly with Onshape for the first few week now all of a sudden it has stopped as you say Space navigator thinks it is still in Chrome not Onshape. How do I sort it out Onshape support seams to think it is not really their problem  
  • joseph_terpendjoseph_terpend Member Posts: 17
    So the Space mouse was not working at all because I was not creating anything new just opening an existing document. As soon as I created a new document it started working and showed that it had changed over to Onshape. I then closed Onshape and reopened it and the Spacemouse is now working as it used to no problem. Conclusion if your spacemouse is not working just create a new doc and it will trigger Spacemouse to change from Chrome to Onshape. You are welcome. 
  • 3dcad3dcad Member, OS Professional, Mentor Posts: 2,466 PRO
    Do you have newest drivers? I haven't seen this problem in a long time, with earlier drivers it happened every now and then.. Sometimes it started working out of nowhere but usually I shut down the 3dconnexion processes and start again.
    //rami
  • wayne_huthmakerwayne_huthmaker Member Posts: 6 PRO
    So the Space mouse was not working at all because I was not creating anything new just opening an existing document. As soon as I created a new document it started working and showed that it had changed over to Onshape. I then closed Onshape and reopened it and the Spacemouse is now working as it used to no problem. Conclusion if your spacemouse is not working just create a new doc and it will trigger Spacemouse to change from Chrome to Onshape. You are welcome. 
    That fixed it for me too. Thanks Joseph!
Sign In or Register to comment.