Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape, CAD, maker project and design.

First time visiting? Here are some places to start:

  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Random glitches since the update. Refresh helps.

dave_schratdave_schrat Member Posts: 11
Resetting a mid plane to different extruded faces selected it would keep choosing a revolve.  The revolve wasn’t even that close in distance.  Hiding the revolve would not help.  Selected 3 surfaces and deleting the revolve would remove the other extrude faces.  Refresh and it worked as intended.

Not being able to select parts of a sketch to extrude.  It would select the entire sketch.  I would grab a few features and then it would grab the entire sketch.  Refresh and selected as desired.

Said it was over constrained but didn’t show any red constraints.  Refresh and there it was.

I have had more but it is faster to just refresh and keep working than keep track of them.  At first, I thought it was maybe my inexperience with the program.

I am also getting the grayed out italic feature tree much more often.  I notice others mentioning this.  Sometimes I think it is faster to refresh the browser than wait for the program to figure it out. 

I have totally restarted my project since the update and reorganized how it is structured.  It now has less features and a relatively small project (130 features).  I doubt this is the problem. 

Error report would do nothing since reloading the program fixes the glitches.  So I am putting it out here to see if others have similar experiences or someone can tell me how to fix it.

Answers

  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 1,447
    What is your computer setup? Everything at the latest version?
    Neil Cooke, Director of Technical Marketing, Onshape Inc.
  • dave_schratdave_schrat Member Posts: 11

    These days, can you not have the latest versions?  Everything is auto update.  Windows and Firefox are auto updated.  I ran across the speed compatibility test.  Older computer with not great results but compatible.  Only really noticed the problems in the last few weeks.  Is there a way to run in the previous Onshape version?



  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 1,447
    There is no previous version. Not sure what to suggest. What about graphics drivers? 
    Neil Cooke, Director of Technical Marketing, Onshape Inc.
  • dave_schratdave_schrat Member Posts: 11

    Intel HD Graphics 4000 is up to date but might be the problem.  Sketchup seems to have a problem with this graphics card.  Sketchup users reported random screen freezing of a few seconds with no clear reason or solution to fix it.  Intel and Sketchup both pointed fingers at each other and no one accepted responsibility.

    I don’t understand which operations are handled locally or remotely but it does not seem like the problems I am having would be a result of a video board. ???

    When I restructured my design, I copied the file to new one.  I then deleted studios and started over in one of the old studios.  I rolled back to the beginning to start redesigning and roll forwards a little ways to correct any issues.  I did this every 10 features until I was back to the 130 features.  So, in the history of this file there is a whole lot of stuff with the original design and now the redesign work.  Onshape saves all this?  I wouldn’t think so, but would this affect the files performance?


  • brucebartlettbrucebartlett Member, OS Professional, Mentor Posts: 1,577 PRO
    edited January 12
    Are you using derives? Derives can cause problems if placed near the end of the feature tree.

    Are you seeing the problem with the big circle spinning or the small one at the bottom? I could be wrong but my understanding is the big circle in the centre is related to local graphics loading and the small spinning circle is things loading in the backend on the cloud somewhere.

    On chrome when I do a refresh I hold shift as this is supposed to clear the cache.  
    Engineer ı Product Designer ı Onshape Consulting Partner
    Twitter: @onshapetricks  & @babart1977   
Sign In or Register to comment.