Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:

  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Rotation with 3DConnexion SpaceNavigator

thevenot_vincentthevenot_vincent Member Posts: 1
Hello,

I'm using a 3DConnexion SpaceNavigator and I don't find how to have the same behavior as the standard mouse to rotate my part. With my SpaceMouse, the rotation center is always the origine of my part, but with my standard mouse the rotation center seems to be the screen center (more convenient to work on a detail).

I didn't found any information on that. Any Idea ?

OSX : 10.12.6
3DConnexion driver : 10.6.0
Firefox : 64.0

Comments

  • EvanEvan Onshape Employees Posts: 46
    Thank you for bringing this to our attention.  This appears to be a regression in functionality, as the center of rotation used to dynamically update based on viewing conditions.  We have filed an issue and are investigating to determine whether the issue lies in the Onshape client or with the 3DConnexion drivers.
  • Stefan_DMSStefan_DMS Member Posts: 43 PRO
    I don't have the same issue.
    Chrome: 71.0.3578.98
    3Dxware: 10.5.10
    I'm pretty sure I get rotation through the centre of part (not the origin axis), same axis with mouse and space navigator. 
    Thought this might help.


  • paul_noepaul_noe Member Posts: 3 PRO
    I'm having issues with My SpaceNavigator as well.

    Chrome: Version 71.0.3578.98 (Official Build) (64-bit)
    3Dxware: 10.5.12

    I recently reinstalled and upgraded 3Dx software. Prior to that the mouse wasn't responding at all. Afterwards, it worked just like it should...
    for a little while. Now I can only get it to zoom in and out (in rather slow, glitchy increments) regardless of what I do to manipulate. When I read Evan's comment about regression in functionality that would be the exact way to describe my issue.

    Thanks.
  • owen_sparksowen_sparks Member, Developers Posts: 1,996 PRO
    That sounds like it's forgetting it's active application is Onshape. If you go into the config does is show Onshape or the name of your browser?
    Production Engineer
    HWM-Water Ltd
  • TimRiceTimRice Member, Moderator, Onshape Employees Posts: 175
    @paul_noe
    This happens to me occasionally and typically a shift + refresh fixes the issue. A full computer restart is required sometimes.
    Tim Rice | User Experience | Support 
    Onshape, Inc.
  • NunoNuno Member Posts: 13
    3Dconnexion here.

    In the last few weeks, we released updates to our drivers for macOS and Windows with a change that may address some of the issues reported in this thread.

    Make sure you're running v. 10.6.1 of 3DxWare 10 for macOS (released Jan 10) and v. 10.5.12 of 3DxWare 10 for Windows (release Dec 18).

    After upgrading your driver installation on Windows, please check if the rotation center "Auto" option is enabled. For this, sign in to Onshape and open the "3Dconnexion Properties". Ensure "Onshape" is the selected driver configuration (if it isn't, click on the view window of Onshape and confirm the driver changes configurations) and open the "Advanced Settings" panel (press the button with the same name). On this panel, click on the "Rotation Center" tab and ensure the "Auto" option is enabled.

    On macOS, simply delete the file at the following location:
    ~/Library/Preferences/3Dconnexion/navlib/Onshape.user.config
    After deleting the file, refresh Onshape and confirm if the rotation center position is located on the model when viewing it up close.

    As always, the 3Dconnexion technical support team is available to assist our customers, users of 3D mice and Onshape. For the contact details, please visit http://3Dconnexion.com/service

  • owen_sparksowen_sparks Member, Developers Posts: 1,996 PRO
    edited January 15
    Great info. and thanks for dropping by to let us know. 
    I'll be upgrading soon.
    Cheers, Owen S.
    Production Engineer
    HWM-Water Ltd
  • Evan_ReeseEvan_Reese Member Posts: 87 PRO
    Nuno said:
    On macOS, simply delete the file at the following location:
    ~/Library/Preferences/3Dconnexion/navlib/Onshape.user.config

    I'm having trouble finding this location. I found ~/Library but inside I only see Caches. Any tips?
    Evan Reese / Agency Owner and Industrial Designer
    Website: fractalhardware.com
    Instagram: @evan.reese.designs
  • NunoNuno Member Posts: 13
    I'm having trouble finding this location. I found ~/Library but inside I only see Caches. Any tips?
    Hi Evan,

    Please confirm you have a tilde character at the very beginning of the file path.
  • Evan_ReeseEvan_Reese Member Posts: 87 PRO
    @Nuno
    I was able to locate and delete the file but it still seems to rotate around a point off the screen when I'm zoomed in. I've got another thread going about this issue here
    Evan Reese / Agency Owner and Industrial Designer
    Website: fractalhardware.com
    Instagram: @evan.reese.designs
  • NunoNuno Member Posts: 13
    Hi Evan,
    @Nuno
    I was able to locate and delete the file but it still seems to rotate around a point off the screen when I'm zoomed in. I've got another thread going about this issue here
    Does this track a particular document? In other words, does it work as you expect if you create a simple box model?

    There may be something else: did you delete the file for the same user that runs the web browser program (used to access Onshape)?
Sign In or Register to comment.