Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

WEBGL problem in google chrome

Hi, I come with a problem that I can't solve. I have Chrome and I can't open the files because it says:
It looks like your browser doesn't have WebGL enabled. Click here for more information.
I made several tweaks in Google Chrome and I could not reach anything.
Any information on what things I would have to activate or how to fix it?
This started to do now.

Comments

  • jakeramsleyjakeramsley Member, Moderator, Onshape Employees, Developers Posts: 602
    Hi sebastian_wolfenson,

    Can you check the steps outlined in our help documentation:  https://cad.onshape.com/help/Content/webgl.htm#WebGL also, there is a blurb about blacklisted graphics cards for WebGL listed here: https://www.khronos.org/webgl/wiki/BlacklistsAndWhitelists.
    Jake Ramsley

    Director of Quality Engineering & Release Manager              onshape.com
  • Henk_de_VlaamHenk_de_Vlaam Member, Developers Posts: 177 ✭✭✭
    edited December 2019
    @jakeramsley,
    Since  a few days I've the same problem here on two of three PC's with Chrome versie 79.0.3945.88 (Officiële build) (64-bits).
    I checked your suggestion, however without success.
    With Mozilla no problems. 
    Henk de Vlaam (NL)
  • EvanEvan Onshape Employees Posts: 58
    It appears there has been a regression in Chrome 79 that has caused WebGL to fail on some older GPUs.  If this is affecting you, I encourage you to "star" the issue on Chrome's bug tracking website:
    https://bugs.chromium.org/p/chromium/issues/detail?id=1036367

    First click the "Sign in" link on the upper right to sign in with a Google identity, then click the star on the bug in the upper left.  This will help Chrome track affected users.

    It could also be helpful to know the model of GPU you are using. 
  • sebastian_wolfensonsebastian_wolfenson Member Posts: 7
    Perfect thank you very much, for now I will continue using it in Mozilla Firefox because I didn't find a solution in Chrome.

    Thank you
  • eduardo_rodriguez688eduardo_rodriguez688 Member Posts: 3 EDU
    Same problem here. It was working fine until today.  Was there an OnShape update of some sort?  It's hard to teach a class this way.

    "It looks like your browser doesn't have WebGL enabled."

    Is there a quick fix for this?

    Any help will be appreciated it.

    Mr. Rodriguez
  • EvanEvan Onshape Employees Posts: 58
    @eduardo_rodriguez688 - WebGL issues tend to arise from an interaction between the browser and system level drivers.  It's a possibility that a Chrome update disabled the gpu due to stability issues.  That can be overridden with a browser change.  See here for more details: https://cad.onshape.com/help/Content/webgl.htm#WebGL
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 3,018
    I also had dealings recently with a school district that disabled hardware acceleration in Chrome. Worth checking?
Sign In or Register to comment.