Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

3Dconnexion SpacePilot (not Pro) - has anyone mastered proper setup for 3D navigation in OS?

OK, I know, there are newer 3Dconnexion devices. Anyone has one - I'm jealous!
I'm not so heavy user of CAD systems to deserve such a luxury :-(
But now as I've been promoted to OS Pro user I decided to give another chance to that old friend in OS.

I have installed the last driver that supports that device. It works perfect in all Windows apps. (Win64 7Pro, 3DxWare64_v10-4-10_r2558)
It works in OS also but... navigation is awkward. In all other apps moving a 3D mouse moves/rotates an object in a way that resembles having a real object in a hand.  So, it's a camera view.
In OS, I can't set up panning, and rotation is affecting always object instead of a camera. No matter what is checked-up in a 3DCon Config panel.

Is anyone using such a dinosaur? Has managed to set it properly?

Sign In or Register to comment.