Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

How do I set up my GPU to run in Onshape?

Katie_BosilovichKatie_Bosilovich Member Posts: 2
edited October 2020 in Community Support

I think I've read the Graphics Performance Help page at least ten times and I'm very frustrated. I have a GeForce RTX 2070 graphics card, but whenever I run the compatibility check, it says Google Swiftshader is being user to render the graphics. I have done everything the help page has said, and it still won't work. If anyone can help me figure this out, I'd really appreciate it, because as it is now, it takes minutes for onshape to register any interaction I have with parts.

Best Answer

Answers

  • TimRiceTimRice Member, Moderator, Onshape Employees Posts: 305
    edited October 2020

    Hi Katie! Do you have multiple graphics cards installed on your device? Assuming you are using Chrome on a Windows device, you can ensure Windows defaults to the better graphics card by navigating through your system settings to Graphics settings and ensuring your browser is set to High performance. From there you can also ensure WebGL and hardware accelerated are turned on:

    Go to chrome://settings

    1. Click the Show advanced settings link
    2. Scroll down to the System section and ensure the Use hardware acceleration when available checkbox is checked
    3. Relaunch Chrome for any changes to take effect

    Check Onshape at this point. If it's still not working, you can try to force WebGL hardware rendering via the following:

    1. Go to chrome://flags
    2. Enable the flag called Override software rendering list


    Tim Rice | User Experience | Support 
    Onshape, Inc.
  • PeteYodisPeteYodis Moderator, Onshape Employees Posts: 418
    edited October 2020

    @Domenico_D Windows 10 has replaced the need to access the nVidia Control Panel for setting the GPU preference per application. The area is under Graphics Settings. It's a more generalized approach regardless of the graphics card vendor, nVidia, AMD, Intel, etc...

    You can see what mine looks like here:

    @Katie_Bosilovich is your question answered with Domenic's suggestion? Were you aware of the Windows 10 Graphics Settings area? Can you provide a screenshot of what that looks like for you?

  • matthew_stacymatthew_stacy Member Posts: 277 PRO

    @Katie_Bosilovich , I just went through the similar issue. In my case changing the display setting in my browser (Firefox) fixed the problem (somewhere in the Firefox>options if I recall correctly). The default setting utilizes the integrated graphics hardware to conserve power. There is high-performance setting to override that to utilize your GeForce GPU.

  • emagdalenaC2iemagdalenaC2i Member, Developers, Channel partner Posts: 665 ✭✭✭✭✭
    @PeteYodis or @lougallo Please, could you create an Improvement request to add that information in the Graphics Performance Recommendations ?
    Un saludo,

    Eduardo Magdalena                           C2i Change 2 improve                           ☑ ¿Por qué no organizamos una reunión online?   
                                                                 Consulting Partner de Onshape                                      Averigua a quién conocemos en común


                                         Live Chat at Discord about Onshape & FeatureScript

    Consulta mis cursos de Onshape en Español:
Sign In or Register to comment.