Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.


Problem with Onshape and Google Chrome

dan_snyderdan_snyder Member Posts: 1 ✭✭

I have been using Onshape on Google Chrome on a desktop for over a year and Onshape works fine. However, the latest update of Chrome, version 86.0.4240.75, gives all my Onshape documents a black background, which makes it useless. Things are OK if I use the Firefox browser. Things are also OK if I revert to Chrome version 85.0.4183.83, but Chrome automatically updates to the latest version after a day or so. Chrome has always worked the best for Onshape on my hardware. Has anyone else had this problem?




  • Options
    PeteYodisPeteYodis Moderator, Onshape Employees Posts: 526


     There was recently an update to Chrome/Windows graphics that seemed to have made things more strict on older graphics cards. Today you can follow these rules here to get Chrome back up and running:

    Ensure WebGL is on and hardware accelerated first:

    1. Go to chrome://settings
    2. Click the Show advanced settings link
    3. Scroll down to the System section and ensure the Use hardware acceleration when available checkbox is checked
    4. Relaunch Chrome for any changes to take effect

    Check Onshape at this point. If it's still not working, you can try to force WebGL hardware rendering via the following:

    1. Go to chrome://flags
    2. Enable the flag called Override software rendering list

    I have created a ticket for you for more discussion of the particulars in your case. So far, I have seen this happening on much older devices.

  • Options
    bob_jones984bob_jones984 Member Posts: 2
    This fixed my problem, thanks!
  • Options
    earl_simpsonearl_simpson Member Posts: 2
    For Edge, it's similar. The link is edge://settings/system. So, Settings > System and performance and then enable "Use graphics acceleration when available".
  • Options
    yash_bhagat994yash_bhagat994 Member Posts: 2
    Thanks fixed my problem too!
Sign In or Register to comment.