Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

I have an image from one document inserted into all my other documents, and I can't delete it.

ian_harris952ian_harris952 Member Posts: 6
edited February 20 in Community Support
I have quite a few drawings in Onshape, some quite old. A few days ago I started a new document and inserted an image into it. Now the image has been inserted into EVERY tab in ALL my documents, and I can't delete it. I've tried deleting (well, moving to trash) the document I created with the image in it, but that had no effect. I've screwed something up big time, and I'd like to get all my documents back as they were. What do I have to do?

The document causing the problem is called Decathlon and is here. https://cad.onshape.com/documents/0ed9041c1cfb5f31322bec59/w/a502cbf4d3339ecda48407a2/e/525764261e68ea71beb257af. This is a document I created just before Decathlon, which now has the image in it and didn't before. https://cad.onshape.com/documents/23b2d01bf83dcfec1cd2092e/w/a6579482bf50357f13dbcac6/e/8b449796f5f1c06a81896a85. I've also checked some of my older documents and they all seem to have the image embedded.

The only thing I did differently this time (as I've had problems tracing images) was to "fix" the image once I'd inserted and sized it, as I always had problems with the image moving when I tried to select entities in the drawing. (I've posted another question about this problem). I've also tried deleting the image from the Decathlon document, which I could do once I had "unfixed" it, and the image did look like it had been deleted (I could move it too) but the phantom image remained (and still fixed apparently as it has a black outline) and is still present in all my other documents.

I believe all my documents are public anyway, but I've never done this before so if I need to do anything else to make them viewable please advise. I have "shared with Onshape support" the documents: Decathlon, TxCase, Calmato Wing, and Cassutt.

EDIT1
I have also found if I  create a new document the image is there before I do anything, no sketches, nothing.

EDIT2
In fact it's not just the image, it's the whole sketch from Decathlon. Again I can move entities in the sketch but they appear to be copied, not moved. I can delete entities and they appear to be deleted but are still displayed. And I can't select them any more.

Thanks, Ian.

My userid is mogplus8 if that helps.


Answers

  • ian_harris952ian_harris952 Member Posts: 6
    Well, I don't know what happened but the problem seems to have gone away. Could I have accidentally set the sketch as a default background or something?

    :-\ Ian
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 3,611
    No, it was likely something to do with your graphics. If it happens again try deleting the cache on your browser. Also make sure that all your drivers and browser version are up to date. 
    Director, Technical Services, EMEAI
  • ian_harris952ian_harris952 Member Posts: 6
    Thanks for the response. I'll try that next time. Which hopefully there won't be one.

    ;-) Ian
Sign In or Register to comment.