Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Parts keep disappearing from assembly

tony_459tony_459 Member Posts: 206 ✭✭✭
edited January 24 in Using Onshape
I have a large assembly in which parts keep disappearing for no reason whatsoever. The parts exist and they look great in the part studios. But there is no trace of them to be seen in the assembly tab despite their names being clearly listed in the model tree pane. And if I try to insert a new instance of the missing parts, tough luck---the name will show up in the model tree pane but there will be no trace of the newly inserted part in the visualization pane. This seems to affect only some parts and I have no clue why.
Some of the missing parts are attachment points for actuators... which move as though they were still attached to the missing parts... suggesting this is purely a visualization issue?
Still, CAD is a visual tool and if you can't see your model, then you don't have a model. It seems important that your parts should be visible so that you can work with them?
Has anyone else run into this issue? What was the problem and how did you work around it? Why would parts randomly disappear from an assembly?

Comments

  • tony_459tony_459 Member Posts: 206 ✭✭✭
    There seems to be more and more parts missing each time I go back to my assembly tab. The actuators I mentioned earlier can no longer be seen, and frankly I think about half the model is now missing. This is not just transient loading, because the tab is just sitting there open and still no sign of the missing parts. I've spent an hour loading and reloading and waiting waiting, and still all I have is a fraction of the assembly I had earlier today. 
  • tony_459tony_459 Member Posts: 206 ✭✭✭
    edited January 24
    OK, it seems Windows has decided that my very expensive NVIDIA GPU should not be used with my web browser despite my specifically explicitly unambiguously specifying in my settings that my very expensive NVIDIA GPU should be used with my web browser.
    Hoping this explains the mysterious missing parts.
  • tony_459tony_459 Member Posts: 206 ✭✭✭
    Nope. Just verified that my very expensive NVIDIA GPU is running with my web browser, but still, the missing parts are very much still completely missing. I feel like this shouldn't be a thing with visual tools like CAD---parts shouldn't just randomly up and disappear. Isn't it problematic if you can suddenly no longer see your parts? 
  • john_mcclaryjohn_mcclary Member, Developers Posts: 3,720 PRO
    edited January 24
    Have you tried refreshing your cache? Or doing a full reload Ctrl+F5
  • tony_459tony_459 Member Posts: 206 ✭✭✭
    Yep! 

    But turns out the fix came from elsewhere. I had a number of Derived parts which weren't fixed to a specific version. They were just the latest from Main. I won't pretend to know exactly this should be a problem, but I do know that specifying a version number for the Derived parts fixed the issue. That is all I had to do. 

    Derived parts have been a problem in other large assemblies, and I figured maybe they were to blame in this case too, even though the issue was of a different nature.

    So whew, this particular assembly lives another day :)
Sign In or Register to comment.