Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Onshape render lighting help?

MichaelPascoeMichaelPascoe Member Posts: 876 PRO
edited February 1 in General
Having issues getting the lighting to apply to a face or a part. Does anyone know how to get the lighting material to emit light? @GregBrown I have moved the question to here. 

I have tried changing the environment in case this scene was too white. Anytime I get the lighting to work, it is never a glowing light, only a white color. Also tried assigning the light material to a part instead of a face.

Thanks in advanced! So excited for Onshape rendering.

Here is a link to the document:
https://cad.onshape.com/documents/6c4ae7073bbb41d485299a31/w/a75a42c352a4a591769b844c/e/45fdcd609bd61e6c1bb3860d


Best Answer

  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 4,315
    Answer ✓
    Director, Technical Services, EMEAI

Answers

  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 4,315
    Answer ✓
    Director, Technical Services, EMEAI
  • MichaelPascoeMichaelPascoe Member Posts: 876 PRO
    @NeilCooke I must be doing something else wrong too. 
















  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 4,315
    edited February 2
    Try an "emitter" material instead - you'll also have to tweak that bloom threshold number. I also struggled to get diffuse light to bloom.

    EDIT: actually I can get diffuse light to work if bloom radius is 0.05 and threshold is 500000
    Director, Technical Services, EMEAI
  • MichaelPascoeMichaelPascoe Member Posts: 876 PRO
    edited February 2
    Many thanks! With the original bloom options you suggested, I got it to work by adjusting the settings for "Cool White 7000k Emitter". 





  • andrew_kleinertandrew_kleinert Member Posts: 43 PRO
    Thanks @MichaelPascoe and @NeilCooke for this, good resource to get started with creating a light source. 

    To add to the topic ...

    I found that the "Add Emission" environment to be a little more flexible, allowing the colour to be selected.

    Assign "Add emission" environment

    Typically the material will first appear black meaning that the light source is "off" (or a low value lumens indicating that it is as good as "off")

    Under Appearance -> Global, I set the "unit for emission" to "lumens" (to be consistent with the emitter environments above)

    Set the lumens to a big value (eg: 1000, 10000, 100000) to turn the light source "on"

    The colour selector  in the Appearance -> Global dialogue is fairly self explanatory.

    As you can see below, some of the colour rendering can be a bit funky for curved surfaces + low lumens values (the part being rendered below is a singular homogenous part) - haven't figured out what's causing that but it's not holding up my work.


Sign In or Register to comment.