Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Part Number generation and revisions for different branches

S1monS1mon Member Posts: 986 PRO
I've created a branch of a document which just has a single part studio in it. One branch is one flavor of a design and the other branch is second one. Each should have its own part name, number and revision. It doesn't seem like this is a well supported use case.

Normally in Enterprise, the part number button will generate a new part number, but if the part already has a part number the button doesn't work. I can still manually enter a number, but I might accidentally enter a part number which is being used somewhere else. I'm fine if for other use cases, this button would normally want to be grayed out, so maybe there just needs to be a warning dialog.

If I change the part number in the release dialog, the revisions don't reset to 1 (in this case, we're using a 1, 2, 3.. revision scheme). If I enter a new part number in part properties first, then when I make a release, the revision number starts at 1. This seems inconsistent and weird.

Comments

  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 4,375
    You don’t have to enter a part number manually, just clear the field and press the button and the next available number will be assigned. But, it won’t automatically clear the revision field, you would have to manually set that to 1. It works from part properties because the data in the release candidate is populated when the dialog opens. 
    Director, Technical Services, EMEAI
  • S1monS1mon Member Posts: 986 PRO
    In this case, I have one branch which already had a part number, revision and release. When I tried to create a different part number, and new revision and release in the the second branch, I had to enter the new number manually. The new number button is grayed out and doesn't do anything.
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 4,375
    Hmm, works for me, just tried it and I can't see any RM settings that would prevent this.
    Director, Technical Services, EMEAI
  • S1monS1mon Member Posts: 986 PRO
    I get this: 



    With that cursor, I click and nothing happens. I can enter a new number manually.

    I also looked through the release management settings in our enterprise settings. I don't see anything that would change this behavior.
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 4,375
    Try clicking in the text box and pressing delete to clear the field first. 

    Director, Technical Services, EMEAI
  • S1monS1mon Member Posts: 986 PRO
    Yep. That works. Somehow that didn't occur to me.

    I would much prefer that the button always works, and maybe if the number is already filled, there's a warning dialog which says something like "Do you want to overwrite the current part number?" Getting that cursor with the circle and the slash through it really made me think that I couldn't make a change at all.
Sign In or Register to comment.