Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Onshape 3DConnexion Spacemouse Chromebook Integration?

tucker_thomas029tucker_thomas029 Member Posts: 4 EDU
I'm trying to use my Spacemouse wireless with Onshape on a Chromebook for a school course.  Is there a way for this integration to work?  Chromebook natively supports Spacemouse for their web apps, like Google Earth, but when I try to use it in Onshape, nothing happens.  I have tried to install the 3DX drivers via the Linux command line for Chromebook, but I get various errors, including some directories being missing and not having a program called Red Hat EL 7 (which I tried to install but couldn't).  I have an education subscription to Onshape.  Is there an alternative way to do this? Some menu I'm missing? Thank you for the help.

Comments

  • tucker_thomas029tucker_thomas029 Member Posts: 4 EDU
    Upon further experimentation, I was missing several typefonts that were easy to install (and are listed in 3dxWare's info file). RHEL7 is only necessary for automatic startup.  I was able to install the drivers, but the issue comes when I try to start them.  When attempting to start the drivers, I get this error message:

    Error: 3dxsrv.c :: startupCommandLine(), authGetUser(), failed to get user.

    This occurs even when I run the command with administrator permissions (sudo).  I think it may have something to do with Chromebook being unable to detect USB devices through the Linux environment.  Is there any way to fix this?
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 4,629
    Have you tried asking 3Dconnexion? Not sure anyone would have tried this here.
    Director, Technical Services, EMEA
  • NewFatMikeNewFatMike Member Posts: 5
    RHEL is Red Hat Enterprise Linux, which is an entire distribution (operating system) unto itself, not a program. I believe ChromeOS is built around Debian, a separate distribution with different structures. I’m out of my wheelhouse, but it may be worth checking with 3DConnexion and maybe some Linux-forward forums like Level 1 Techs if it’s even possible.
  • NewFatMikeNewFatMike Member Posts: 5
    I did some digging because I would actually like to use my new Spacemouse with my Steam Deck, and found open source drivers which ought to be installable on your Chromebook:

    Spacenav web site (sourceforge.net)
Sign In or Register to comment.