Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.


Sketch entities not pasting to clipboard?

Here's the document for reference: https://cad.onshape.com/documents/b843b066d20cbd3b92bee619/w/bae45e76e10472e4ae309d5c/e/01e8f9f78a665c87bf8c03b1?renderMode=0&uiState=63fdcc3d8da34655cb0cb958

The sketch in question is labeled as "Sketch 4" in the part studio tab named "Side Panel"

So I made a pattern and extruded it onto the part in the tab labeled "Side Panel". Since I planned to extrude the same pattern onto the "Cap Panel", a slightly different but similar part, wanted to copy only the outline/edges of the Side Panel part and its pattern and none of the extra sketch entities that I used to make pattern. So I made a new sketch, Sketch 4, on the top plane, selected the face of the Side Panel, used the Project/Convert function to get the edge outline/sketch lines of the face, then selected all of them and right-clicked and selected "copy sketch entities." I then switched over to the Cap Panel tab and created a new sketch on the pace of that part. When I tried pasting the sketch entities, however, I got the message "Clipboard is empty."

I was pretty sure I copied everything or at least something, so I went back, selected everything again, tried copying and pasting again, and I still got the message "Clipboard is empty". I also tried selecting the sketch itself from the design tree, and that doesn't work either. I don't know what's going on, and I wanna know what the problem is and why the sketch entities won't paste. I've already found a workaround: Selecting all the sketch lines, using the Transform function to move them away a bit then selecting them, and only then do the lines seem to actually be copied into the clipboard and can be pasted. However, I just want to know what the problem is so that it can be addressed and fixed. I've already thought of some probable causes: Maybe there are too many projected/converted entities, and the selection of sketch entities becomes too complex to copy to the clipboard. I've tried copying small parts of the sketch and that seems to work fine, and with a larger selection of the sketch it starts to refuse to copy them to the clipboard.

Any help on this problem is appreciated. I've also already tried using a different computer to solve the problem and I got the same results, so feel free to try replicating and solving the problem as well.


Sign In or Register to comment.