Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Extruding Not Working?

chloe_chen866chloe_chen866 Member Posts: 7
My extrude isn't working, I am sure my sketch is closed.

Answers

  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 5,253
    A region is closed if it is shaded.
    Senior Director, Technical Services, EMEAI
  • _anton_anton Member, Onshape Employees Posts: 244
    edited March 2023
    Is any region (or multiple regions) in the sketch meeting at a single point? Extruding that as a single part would create nonmanifold geometry, which our geometry kernel disallows.
  • eric_pestyeric_pesty Member Posts: 1,391 PRO
    You might have also have some "zero thickness" geometry in there that could be giving you trouble
  • chloe_chen866chloe_chen866 Member Posts: 7
    If I go out of the extrude mode everything is shaded, so I know it is all closed
  • eric_pestyeric_pesty Member Posts: 1,391 PRO
    Actually I think I see the problem in the image: you have the extrude set to "intersect" and no "scope". Try setting it to "new" instead...
Sign In or Register to comment.