Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

STL export seems broken

I've tried a bunch of different .STL exports and unless using the 'custom' quality settings it will just export a 0kb empty file. Could someone look into this? 

Comments

  • michael3424michael3424 Member Posts: 533 ✭✭✭
    Can you share the file publiclly as well as the export settings you used so that other users can take a look?  I just exported an Onshape part as a custom STL using the default settings and that worked fine for me. 
  • lougallolougallo Member, Moderator, Onshape Employees, Developers Posts: 1,849
    Do you have any special chars in the file name?  Send in a ticket using th ? Menu -> Feedback and we will take a look. 
    Lou Gallo / PD/UX - Support - Community / Onshape, Inc.
  • daniel_chowdaniel_chow Member Posts: 108 ✭✭
    Are you using Chrome?
    In Chrome, try using Incognito mode.
    Try a different computer / browser
    Can your browser download other files from the internet? 
    I don't think this matters, but is your design full constrained (black lines)
  • brian_garretbrian_garret Member Posts: 2
    Thanks for the feedback, here is the link to the public document: https://cad.onshape.com/documents/0273d8e88d70459f847f7a71/w/edc9982105c74e4ea07d1a4f/e/b3cea39b91dc429bb5c190de

    I've done some more investigation and good news is it almost always works fine, except when you choose the option to "download and store file in new tab". The file gets exported but is completely empty, I've checked it with Sublime text editor and there is nothing inside. 

    It should be easy to reproduce and fix, see attached screenshot, I'm using the latest Chrome browser on a Mac.


Sign In or Register to comment.