Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Options

Sizes and positions change uncontrollably

klaus_krämerklaus_krämer Member Posts: 31 ✭✭
A picture tells more than thousand words:

This happens, when I add a text and subsequently add a midpoint constraint:

Before:

After:


You see, the text has increased its size significantly without any real purpose. Similar things happen to dimensionings in sketches which sometimes simply become unreadble unless the are manually repositioned. The latter gets annoying when sketches are parameterized.

Is there any way to switch this unwanted behaviour off?

Comments

  • Options
    GWS50GWS50 Member Posts: 379 PRO
    Put a dimension on the text box, either horizontally or vertically to constrain the text to a particular size
  • Options
    klaus_krämerklaus_krämer Member Posts: 31 ✭✭
    @GWS50 That's not my problem. It's any uncontrolled change of size or position of elements! What has a midpoint constraint to do with the size of the element i add the constraint? Nil - as long as there are no other constraints. That's bothering me.
  • Options
    GWS50GWS50 Member Posts: 379 PRO
    Someone with more knowledge than me will be able to help you! 😀
  • Options
    S1monS1mon Member Posts: 2,359 PRO
    The first constraint (which would drive a change in size) or dimension you add to any sketch will scale the sketch. This can be a great feature or a frustration. Typically, where it's very useful is in importing a sketch from a DXF.

    In this case, if you add a dimension first, and then the mid-point, you won't have the issue of the size jumping. You could always delete the dimension after that.
  • Options
    klaus_krämerklaus_krämer Member Posts: 31 ✭✭
    Hey guys, don't get me wrong: The simple question I've asked, was if its possible to switch this behaviour off, not about workarounds. Thank you anyway for trying 👍
  • Options
    S1monS1mon Member Posts: 2,359 PRO
    Nope. There's no option to turn it off. You could create an improvement request.
  • Options
    NeilCookeNeilCooke Moderator, Onshape Employees Posts: 5,370
    It’s just solving based on the top left anchor point of the text. If you don’t fully constrain, things will move. 
    Senior Director, Technical Services, EMEAI
  • Options
    martin_kopplowmartin_kopplow Member Posts: 264 ✭✭✭
    This is a feature not a bug. The 'behaviour' follows the same logic as all sketch elements: To define the size, and keep it when constraining to other sketch elements, just dimension it and you're good to go. We do that all the time with all the entities we find in sketches.
  • Options
    klaus_krämerklaus_krämer Member Posts: 31 ✭✭
    S1mon said:
    Nope. There's no option to turn it off. You could create an improvement request.
    Thanks @S1mon, that's, what I was asking (but not really hoping for). 🙂
  • Options
    S1monS1mon Member Posts: 2,359 PRO
    In this case, you could also use the sketch transform tool to move the text into the right position. In sketcher, select all the sketch entities, pick the transform tool, move the transform reference to the center of the line you want to align, drag the text until it snaps to the correct position, select the origin (or whatever reference) and the vertical line, and add a mid-point constraint.

    This won't change the size.


  • Options
    klaus_krämerklaus_krämer Member Posts: 31 ✭✭
    @S1mon
    That's really something i hadn't been thinking about - thanks!  :D 
Sign In or Register to comment.