Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

3d connexion Pan left and right not working on my mac

Ben_Ben_ OS Professional, Mentor, Developers Posts: 287 PRO
Hey all. I have done a basic search and to be honest some threads did the TL;DR to me... So like any self respecting needy guy I am posting a question that  I hope has been answered already. 

For the life of me I cannot get my SpacePilot to pan left and right... Driving me mental. Here is what I have done so far:

I have a Mac, 3D connexion Spacepilot Pro

-Tried resetting the 3Dconnexion settings
-played with all the buttons on the pilot
-tried remapping the axii in the settings dialog
-tried different browsers safari and chrome 
-uninstalled the drivers (including going in and removing the user/library/prefrences/ folder
-reinstalled
-made a new profile configuration and think I hit every button and toggle in the settings to see if it changed anything
-made sure my drivers are up to date.
-tried the device on my PC and it works flawlessly

Please for the love of all that is holy help me fix this so I can turf my P.C. 




Tagged:

Comments

  • Ben_Ben_ OS Professional, Mentor, Developers Posts: 287 PRO
    HA! For those having this issue you need to:
    1. uninstall the drivers via Applications/3dConnexion
    2. get into the /user (your username)/Library/Preferences/ and remove all the com. files in relation to 3Dconnexion 
    In my case the ccom.3dconnexion.3DMouseHome.plist was the offending file.

    Reinstalled and Voila! now to shelve my PC and Saladworks in hopes of never touching it again.
     
  • HHOHHO Member Posts: 2
    BenE - have You used your SpacePilot with Onshape with Win10 via BootCamp?

    On my Macbook Pro, my SpacePilot works fine with Onshape inside OS X and Safari - BUT I am "forced" primarily to use Win10 as OS through BootCamp, due to other software - and there the SpacePilot functionality inside Onshape is absent...
    And YES, I have installed the latest windows 64-bit driver from 3DConnexion!
    With Chrome there is NO interaction between SpacePilot and Onshape
    With Edge and Firefox there is some kind of zoom-function using the SpacePilot "joystick" (but it is erratic and lagging - so good for nothing)
    Have not tried other browsers
    All my other windows 3D software (CAD & others) works flawless with the SpacePilot 

    We are opting for a new 3D cad software, but I simply cannot decide on Onshape until I know it will work with 3D mouse in Windows BootCamp

    -HHO-
  • HHOHHO Member Posts: 2
    edited June 2016
    EDIT 
    Duplicated post
Sign In or Register to comment.