Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Options

Copied workspace and all my feature list actions disappeared!

drcontempodrcontempo Member Posts: 5
I tried copying my workspace and when I checked my action history, I saw in red "User Code." 

My original document still has the history, and I'm only doing this trick to reduce my document size because my storage limit is being reached! Does anyone know what that User Code is? it's some kind of error it looks like?

Thanks

Comments

  • Options
    kevin_o_toole_1kevin_o_toole_1 Onshape Employees, Developers, HDM Posts: 565
    This is definitely something we don't expect to happen when you copy a workspace, and should be looked at on our end. Can you please either make your document public and post a link here, or share it with support, so we can take a look?

  • Options
    edward_petrilloedward_petrillo Member Posts: 79 EDU
    Same thing happened to me. I filed support ticket https://onshape.zendesk.com/hc/en-us/requests/33806 earlier this morning.  Still unresolved
  • Options
    Stuart_TodStuart_Tod Member Posts: 56 PRO
    Thank you...I thought this was just me too! Happened to my document, filled out a support ticket ( https://onshape.zendesk.com/hc/en-us/requests/33803) as well. The document stayed unusable all yesterday, still is this morning. 


  • Options
    ilya_baranilya_baran Onshape Employees, Developers, HDM Posts: 1,175
    This looks like a bug in the recent update -- sorry!  We are investigating.
    Ilya Baran \ VP, Architecture and FeatureScript \ Onshape Inc
  • Options
    john_f_carrjohn_f_carr Onshape Employees Posts: 74
    We understand the problem and are working on a fix.  People with urgent problems should open support tickets.  Otherwise the history will be visible again once the fix is deployed.
  • Options
    lougallolougallo Member, Moderator, Onshape Employees, Developers Posts: 2,001
    @Stuart_Tod Those numbers for tickets are just for you .. nobody can see them but you and Onshape.  I have tickets logged for you all as well.
    Lou Gallo / PD/UX - Support - Community / Onshape, Inc.
  • Options
    chrisjh777chrisjh777 Member Posts: 207 ✭✭✭✭
    I am also seeing strange things happening including:

    1.   "User Code" issue in one tab of a complex design I am working on.

    2.    Linear patterns or mirroring no longer work.

    3.   Drawings behaving badly like the properties of a view appearing when trying to insert ordinate dimensions or Notes with Leaders.

    4.   When trying to edit this post, I am having great difficulty positioning the cursor, in that whole adjacent text are selected rather than between text.  Maybe my mouse battery is low?

    I have raised separate tickets on Items 1 & 2 above.  I haven't raised a ticket on Item 3, as I now think it must be related to the most recent release.  Hopefully all will be fixed soon.
  • Options
    Narayan_KNarayan_K Member Posts: 379 ✭✭✭
    I m also faced the same issue "User error" while creating "Copy work space". Then i tried to copy a part studio into new document,still the same issue.

    Finally i tried to copy the part studio into existing document(document created before to the new update),this works fine.No "User code " issue.

  • Options
    ilya_baranilya_baran Onshape Employees, Developers, HDM Posts: 1,175
    We broke our ability to copy Part Studios with more than 50 features in recently modified documents -- copies would lose the feature list and show a single "User Code" item instead.  The problem was caused by an interaction of two performance optimizations that slipped through our testing.

    We have fixed the issue and are running a process to repair the affected documents.  Most of the affected documents have already been repaired, so you should be able to make copies once again.

    However, we have not repaired the copies (we are working on a way to do that) so they will still appear with "User Code" in the feature list.  If you need data in these copies, please open a support ticket and share the copy with support.

    We are very sorry about the inconvenience.
    Ilya Baran \ VP, Architecture and FeatureScript \ Onshape Inc
  • Options
    ilya_baranilya_baran Onshape Employees, Developers, HDM Posts: 1,175
    At this point we have deployed what I believe to be a complete fix: when you open a Part Studio with "User Code" (you may have to reload the document), we start a repair process on it.  After a little bit of time (possibly minutes), you should see a feature list again.
    Ilya Baran \ VP, Architecture and FeatureScript \ Onshape Inc
Sign In or Register to comment.