Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape, CAD, maker project and design.

First time visiting? Here are some places to start:

  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

High Resolution Monitors

Hello - I am using a 4K monitor and would like to be able to use Onshape at full resolution without micro icons.  Any way to scale the icons inside Onshape?

Andrew Huffmaster

Best Answer

Answers

  • mahirmahir Member, Developers Posts: 820 ✭✭✭✭
    Ctl-Scroll in in most browsers zooms the page in and out. I've tested with with Chrome and OS seems to behave well. The icons and feature tree zoom in and out while the graphics area is unaffected. Don't forget the feature tree and view cube can be dragged to other parts of the window in case that helps.
  • cliff_simmscliff_simms OS Professional Posts: 4 PRO
    I have this same issue and have not been able to get the feature tree/menu bar to zoom independent of the graphics area.  Either the icons are tiny and graphics area looks great or the icons are normal sized and the graphics area looks coarse/blurred.

    I tried the Ctl-Scrolling mentioned by @mahir and it either seems to zoom the whole page or just zoom the graphics view with no change to resolution.

    I am on a Dell XPS 15 with the 4K screen.

    Ideas?

    Thanks,
    Cliff
  • Jake_RosenfeldJake_Rosenfeld Moderator, Onshape Employees, Developers Posts: 1,109
    edited January 2017
    Hi Cliff,

    Instead of Ctrl-scroll you can try Crtl+ and Ctrl- (Control plus or Control minus) to zoom the UI. Ctrl-0 will return the page to its default zoom level. What browser are you using? This should work on at least Chrome and Firefox.

    Jake
    Jake Rosenfeld - Modeling Team
  • cliff_simmscliff_simms OS Professional Posts: 4 PRO
    Jake,
    Thanks a ton.  The pixel density setting did it.  It looks great now.  You might want to make this the default setting for Windows now too.  The Windows hardware manufacturers are offering bunches of high pixel monitors now to compete with the Retina displays from Mac.
  • Jake_RosenfeldJake_Rosenfeld Moderator, Onshape Employees, Developers Posts: 1,109
    Thanks for the suggestion Cliff, we've put it on our radar to try and make this the default setting without introducing lag to lower end machines.
    Jake Rosenfeld - Modeling Team
  • bill_danielsbill_daniels Member Posts: 234 ✭✭✭
    I just found this thread and, boy I wish I had found it earlier.  Setting Match Pixel Density=ON made a HUGE difference on my 1920x1080 monitors.  This will save my eyesight!  Please make this more widely known.

    What prompted me to look for the thread was spotting a 45" diag. 4K Phillips monitor on display at a MicroTech store for $490.  It was attached to a gaming system with a Nvidia 2080 Ti GPU so I was really disappointed when OnShape Drawings looked like crap on it.  Not knowing about adjusting pixel density made me think it was Onshape's fault.  Now, I'm going back to look at it again.
Sign In or Register to comment.