Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Issue with Import of STP files

paul_howard263paul_howard263 Member Posts: 5
I've just imported several files in stp format from Turbocad. These were all created in Inch mode. When I open them in Onshape I have discovered that they have all been reduced in size by a factor of 25.4. It seems that Onshape thinks they were created as very small MM parts. How can I fix this?

Thanks Much,
Paul Howard

Answers

  • Narayan_KNarayan_K Member Posts: 379 ✭✭✭
    @ paul_howard263 , For me importing from other software(like NX and Solid works)and importing into Onshape works fine.if i create 1in x 1in x 1in block after exporting into Onshape will give value 25.4 mm x 25.4 mm x 25.4 mm.If i want it in Inch i can change work space unit to in so that it will be 1 in x 1in x 1in block.
    There is no option to scale with some factor while importing in Onshape. As a work around you can scale the parts using Transform option after importing in to part studio.

  • paul_howard263paul_howard263 Member Posts: 5
    How do I find out what the workspace units are set to and how do I change them if I need to?
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 5,349
    See the hamburger menu (3 horizontal lines) top left. It could also possibly be the output from TurboCAD is in the wrong units?
    Senior Director, Technical Services, EMEAI
  • paul_howard263paul_howard263 Member Posts: 5
    As best as I can tell, everything in TC is in inches and there are no settings that I can find when I'm doing the export. I'll do some digging on the TC forums to see what they say there.

    Thanks
Sign In or Register to comment.