Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

"Browser doesn't have WebGL enabled" message

konstantin_shiriazdanovkonstantin_shiriazdanov Member Posts: 1,041 ✭✭✭✭✭

yesterday this message suddenly appeared, this what i see in "about:support" page of my firefox 54.0 x64 (OS Win10x64)

as reccomended in help i manually set webgl.force-enabled to true but it didn't help

however i can open OS projects in Microsoft Edge, so i think the problem is in Firefox

Comments

  • Paul_J_PremakumarPaul_J_Premakumar Member, Onshape Employees Posts: 168
    Hello Konstantin,

     It definitely looks like a FireFox issue. A few questions

    - Do you know if there was any recent graphics driver update?  If it has been a while since your last update, can you update your driver?
    - Are you able to load WebGL in other pages , for example : https://get.webgl.org/
    - Does it work on Chrome? If so, please try to use Chrome, while we investigate the issue.

    We have some general troubleshooting information in the documentation : https://cad.onshape.com/help/Content/webgl.htm
  • konstantin_shiriazdanovkonstantin_shiriazdanov Member Posts: 1,041 ✭✭✭✭✭
    hi Paul, it works in Chrome and Edge, but not in Firefox, today after I faced this problem I've installed latest drivers for my radeon rx 460, but it didn't help.
    on webgl.org in firefox i see this message: "Hmm. While your browser seems to support WebGL, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card."

  • Paul_J_PremakumarPaul_J_Premakumar Member, Onshape Employees Posts: 168
    Hi Konstantin,

    It is possible that some setting could have changed, and is now affecting Firefox's ability to work with your graphics card. Can you try refreshing Firefox as indicated here : https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

    If this does not resolve the issue, you may either file a report with Mozilla. You can also contact Onshape support and provide them the output of about:support, we can file an issue with Mozilla on your behalf.
  • konstantin_shiriazdanovkonstantin_shiriazdanov Member Posts: 1,041 ✭✭✭✭✭
    refreshing FF and safe mode didn't help. in any case, thanks for the tips

  • konstantin_shiriazdanovkonstantin_shiriazdanov Member Posts: 1,041 ✭✭✭✭✭
    today firefox installed an update and onshape turned to work
  • Paul_J_PremakumarPaul_J_Premakumar Member, Onshape Employees Posts: 168
    Thanks for sharing the update.
Sign In or Register to comment.