Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Options

Edge will chamfer at 0.01", but won't fillet at 0.01" Why??? The world may never know.

Hello all,

I've been having all manner of fillet problems on this project. It seems that feature is quite picky, yet it gives you no tangible explanation as to why your fillet is failing. At the moment, I am even more puzzled than usual. I am trying to put a 0.01" radius fillet on some text that is extruded to a height of 0.125". The first letter will take the fillet, the last letter will take the fillet. The dot above the I will take the fillet, but all of the letters in between will not take the fillet. There is no red line anywhere, nor is there the appearance of the arrow indicating the direction of the fillet. The face I want filleted is selected, the loading circle spins, and spins, and spins, and spins, then finally disappears. No fillet. I click the green check mark. No fillet, and no red text in the features bar. The Fillet 5 just appears grey. You click on it to edit and no entity is selected.

Here is where things get really odd. I delete the faulty fillet. I click on chamfer, select the face, and set the distance to 0.01". The wheel spins, and spins, and spins, and spins, then the chamfer appears. I click the green check and all appears well; however, down in my list of features it too appears grey, and when you click on it to edit, there are no entities selected. When you click the time generation icon, the chamfer does not appear in the list of features.

What the heck is going on here? I don't feel like adding a 0.01" radius to some extruded text should be particularly difficult, but for whatever reason it cannot be done. I can however, put a 0.003" radius fillet on the text! What about 0.0031" you ask? Nope. I guess that's just one ten thousandth too many and a far cry from the desired 0.01".

Well, I'm stumped and tired, so I need to reach out to the brain trust. Maybe one of you CAD wizards will solve what this rube couldn't.

Thanks,
Kyle

Also, I ignored most of them, but here are few of the error codes I've received tonight if anyone knows what they mean.

a6edc983338718cc0e858da0.
7f049d42aafefbcadd7a7ab7.
3776ec5aaa2ac4cc989e2031.
b143022e10cb75c5c275817a


Best Answer

Answers

  • Options
    kyle_millerkyle_miller Member Posts: 5
    Thank you for the response.

    I can see your point about the intersecting faces, however, when I chamfer the edges there are several places where the chamfers overlap each other and Onshape doesn't seem to care. Why is it so picky about the fillets? Also, I agree about the facets. I converted some text to DXF and uploaded the DXF file, which could certainly be made with fewer facets. I actually started doing that the night I posted my question, but only got as far as completing the P: as it is a tedious process, and I wasn't sure if after all the effort I would see any reward if there is something inherently wrong with the text geometry that would preclude the use of a 0.01" fillet.

    Your assessment of the conditions which will allow the fillet to generate is interesting. Thinking something like that might be the problem, I also tried to radius all sharp corners, inside and outside, with a 0.01" radius, but even after that it still wouldn't allow the fillet. Furthermore, it still wouldn't allow a fillet any larger than 0.003", which was actually quite surprising. I thought for sure I would make some headway in terms of the accepted fillet radius, but no progress.

    As I have little choice, I intend to spline trace the rest of the text to see if I can generate the fillet I am after. If that doesn't work, I guess I'll have to modify the text to have a bit more rounded appearance.

    Thanks for the info and suggestions,
    Kyle
  • Options
    kyle_millerkyle_miller Member Posts: 5
    Hey Neil,

    I finished spline fitting the letters, making sure to round all the corners (inside and out), and it filleted perfectly at 0.01.

    Thanks for the advice,
    Kyle
  • Options
    NeilCookeNeilCooke Moderator, Onshape Employees Posts: 5,524
    Glad it worked out. 
    Senior Director, Technical Services, EMEAI
Sign In or Register to comment.