Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape, CAD, maker project and design.

First time visiting? Here are some places to start:

  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

3D Connexion mouse not working

adam_richardsonadam_richardson Member Posts: 22 ✭✭
I've got a new machine, and so far have not been able to get the 3D Connexion Spacemouse wireless to work in Firefox other than zoom in Onshape. In Chrome, it initially worked with full control, but now is only doing zoom also. I've verified with the viewer that 3D Connexion supplies that it's working properly in that. And I've got all the checkboxes checked for the types of motion for it to control, and the settings dialog is recognizing that Onshape is open (it's not seeing a generic Chrome instance for example). I tried uninstalling and reinstalling, but no change. Am using the latest Windows 10 64-bit driver, 10.5.4.

Any ideas?
«1

Comments

  • chrisjh777chrisjh777 Member Posts: 161 ✭✭✭
    Me too!!
  • lougallolougallo Member, Administrator, Moderator, Onshape Employees, Developers Posts: 1,478
    Anyone else?  What version of Firefox?  In Chrome where it did work have you tried holding down SHIFT and reloading the page?  Have you updated the driver for 3DConnexiin?
    Lou Gallo / PD/UX - Support - Community / Onshape, Inc.
  • KrzKrz Member, Developers Posts: 27 ✭✭
    When I had a problem with my Space Explorer USB then 3dconnexion support asked me to perform the following:

    - Check if the 3DXNlserver is running in the task manager

    - Can this page be openened: https://127.51.68.120:8181/version

    - Which server version is being displayed?

    - If the page does not open you should disable the Firewall.

    - Check again if Onshape works with FW disabled.

    It seems 3dconnexion driver connects to their web server to control Onshape. Whenever I'm in the network with limited access (e.g. at customer with strict firewall rules) then the control in Onshape is limited to move and zoom.

    /Krz

  • chrisjh777chrisjh777 Member Posts: 161 ✭✭✭
    @krz @lougallo

    I investigated @krz's advice and report the following:

    - Check if the 3DXNlserver is running in the task manager. (Yes, can be found under "more details" within Task Manager)

    - Can this page be openened: https://127.51.68.120:8181/version  (No, but if I restart the computer with the IP address still active in a browser tab, the version 1.2.3.14519 appears)

    - Which server version is being displayed? (3DXNIserver Version 1.2.17291.14519)

    - If the page does not open you should disable the Firewall. (Tried this, but still no go, even after reboot)

    - Check again if Onshape works with FW disabled. (Tried this, but still no go, even after reboot)

    Fusion 360 works fine with the USB 3DConnection mouse at all times.  Solidworks 2015 SP5 behaves just the same as Onshape, that is, useless.

    I have a second computer with a wireless 3DConnexion Mouse that works fine with all 3 programs, Onshape, Fusion 360, and Solidworks 2015.


    I have reported the issue with 3DConnexion in Europe (seems Australia does not exist in the eyes of 3DConnexion, and Europe is the default support location for Australia), but to date they have not responded.

    I have always kept 3DConnexion software up to date, maybe that is the problem.

    The frustrating thing is that it worked fine for years, .

  • KrzKrz Member, Developers Posts: 27 ✭✭
    For my Space Explorer USB they recommended me to downgrade to 3DxWare Version 10.4.3 but I haven't done that as SE works for me with latest drivers and full Internet access.


  • adam_richardsonadam_richardson Member Posts: 22 ✭✭
    Per Krz's questions:
    - Yes, 3DxNIServer is running in taksmanager. It shows it as 32 bit, even though I downloaded the 64 bit version of the software.
    - Yes, can access that url, the server version shown is Server version: 1.2.3.14519

    I'm on Firefox 57. My Chrome is Version 63.0.3239.132

    I tried again with Chrome and it was doing the same thing, zoom only. I went into the settings to get the version number (in a new tab), and then came back to the Onshape tab and now the 3D mouse is working properly. And now I go back to Firefox and it's working there too after not working 2 mins ago. Very weird... So I'm not sure what's enabling/disabling it.
  • adam_richardsonadam_richardson Member Posts: 22 ✭✭
    Following up on my last post from a minute ago.... I shut down Chrome and then the mouse stopped working again in Firefox. Start Chrome up (just an empty tab) and then the mouse works again in Firefox. Shut Chrome down and it stops working in Firefox again. No idea why one would be dependent on the other, but that's what I'm getting.
  • Paul_J_PremakumarPaul_J_Premakumar Member, Onshape Employees Posts: 108
    Hi @adam_richardson , You may want to contact 3DConnexion support for suggestions as well. 
  • KrzKrz Member, Developers Posts: 27 ✭✭
    My Space Explorer stopped working in Onshape in Firefox yesterday after huuuge Windows 10 update. The update has reset everything in Windows.
    And as @adam_richardson wrote: SE works in Chrome but not in Firefox alone. If I start Onshape in Chrome then SE works in Onshape in Firefox too. What's going on here? It seems like Firefox blocks some communication to ... where? onshape or 3dconnexion server?
    G
    M
    T
    Detect languageAfrikaansAlbanianArabicArmenianAzerbaijaniBasqueBelarusianBengaliBosnianBulgarianCatalanCebuanoChichewaChinese (Simplified)Chinese (Traditional)CroatianCzechDanishDutchEnglishEsperantoEstonianFilipinoFinnishFrenchGalicianGeorgianGermanGreekGujaratiHaitian CreoleHausaHebrewHindiHmongHungarianIcelandicIgboIndonesianIrishItalianJapaneseJavaneseKannadaKazakhKhmerKoreanLaoLatinLatvianLithuanianMacedonianMalagasyMalayMalayalamMalteseMaoriMarathiMongolianMyanmar (Burmese)NepaliNorwegianPersianPolishPortuguesePunjabiRomanianRussianSerbianSesothoSinhalaSlovakSlovenianSomaliSpanishSundaneseSwahiliSwedishTajikTamilTeluguThaiTurkishUkrainianUrduUzbekVietnameseWelshYiddishYorubaZulu
    AfrikaansAlbanianArabicArmenianAzerbaijaniBasqueBelarusianBengaliBosnianBulgarianCatalanCebuanoChichewaChinese (Simplified)Chinese (Traditional)CroatianCzechDanishDutchEnglishEsperantoEstonianFilipinoFinnishFrenchGalicianGeorgianGermanGreekGujaratiHaitian CreoleHausaHebrewHindiHmongHungarianIcelandicIgboIndonesianIrishItalianJapaneseJavaneseKannadaKazakhKhmerKoreanLaoLatinLatvianLithuanianMacedonianMalagasyMalayMalayalamMalteseMaoriMarathiMongolianMyanmar (Burmese)NepaliNorwegianPersianPolishPortuguesePunjabiRomanianRussianSerbianSesothoSinhalaSlovakSlovenianSomaliSpanishSundaneseSwahiliSwedishTajikTamilTeluguThaiTurkishUkrainianUrduUzbekVietnameseWelshYiddishYorubaZulu
    Text-to-speech function is limited to 200 characters
  • adam_richardsonadam_richardson Member Posts: 22 ✭✭
    Hi @adam_richardson , You may want to contact 3DConnexion support for suggestions as well. 
    Done. Will report back if I hear anything
  • chrisjh777chrisjh777 Member Posts: 161 ✭✭✭
    I am also in conversation with 3DConnexion Support.  Latest is a set of instructions to alter the registry settings.  I am seeking help from a friend who is is much more experienced in IT than I.  I will report back if the registry changes are successful.
  • adam_richardsonadam_richardson Member Posts: 22 ✭✭
    Hi @adam_richardson , You may want to contact 3DConnexion support for suggestions as well. 
    Done. Will report back if I hear anything
    They had me run a log file while doing the steps to recreate the problem, which I've now sent them. They've escalated it to more senior techs, so we'll see what they come back with.
  • collecolle OS Professional Posts: 3 PRO
    I was experiencing the same issue after updating Windows 10 earlier in the week. My SpacePilot Pro was connecting and functioning correctly with both 3DConnexion Test Tools and other CAD software. But, wouldn't connect to OnShape. I updated the Drivers and Chrome but with no change. After noticing that the OnShape was not showing on the SpacePilot LCD and reading @krz post, simply toggling the firewall brought back control temporarily and adding exceptions to the FW for the  3DxNIServer seems to have fixed the issue.
  • michael_hoopesmichael_hoopes Member Posts: 2
    Yes! Like above, but with details:

    I "added another app" in Control Panel\All Control Panel Items\Windows Defender Firewall\Allowed apps: 

    C:\Program Files (x86)\3Dconnexion\3DxWare\3DxNLServer\bin\3dxnlserver.exe

    Then it worked. Windows 10 Version 1709 OS Build 16299.248
  • adam_gearyadam_geary Member Posts: 17 PRO
    I've been having a lot of problems with my 3D Connexion device lately.  I use Firefox exclusively for Onshape and Chrome for browsing, so I don't have anything else muddying up my FF install.

    Problems started when I updated from some much older driver (unknown version) to 10.5.4 in December and it mostly worked, but I had to click out of window and then back into window a couple times every time I toggled from and to my Onshape window.

    This week the driver wouldn't work at all.  No amount of restarting or tinkering would make the 3Dconnexion driver start.  I went out and got the latest version and updated to 10.5.5.

    This worked flawlessly for about a week before suddenly I got a Windows warning that 3dxnlserver.exe had crashed.  After this the driver still worked fine and I could run 3Dconnexion demos and such, but Onshape wouldn't work at all with it.  Restarting and manually running 3dxnlserver.exe did nothing, so I reinstalled.  Nothing.  I uninstalled and loaded older drivers to no avail.  I installed the latest driver again and now Onshape works with my Spacepilot Pro but only if I run it in Chrome...  The Firefox version won't work at all. 

    This is pretty bizarre and I'm really not sure what to do short of reinstalling Windows.  Clearly something got hosed somewhere deep in the registry or something.
  • jackson_kingjackson_king OS Professional Posts: 77 PRO
    I just tried firefox and I can't get my SM enterprise to recognize onshape at all.  It work just fine with chrome (which I usually use).  I run macOS but it sounds like windows users are having the same issues.  Anybody have a workaround?
  • joepjoep Member Posts: 12 PRO

    I tried the following steps and it seems to work. If you are using Chrome.

    1. Close Chrome
    2. Stop the 3Dconnexion driver
    3. Start the driver
    4. Start Chrome and Onshape 

    Best Regards,


  • adam_gearyadam_geary Member Posts: 17 PRO
    UPDATE:  I've tried again to make Firefox work with the Space Pilot Pro and succeeded by downgrading to Firefox 56.0.2.  It's working perfectly now with no hiccups at all.  As far as I can tell, Onshape is working better on FF 56 than it has on the post-57 versions of Firefox which were supposed to be oh so much faster for browsing.  It seems the newer versions have really hosed something about Onshape, at least on my computer.

    Since I use FF exclusively for Onshape and Chrome for browsing, I'm not so worried about the security loss of not upgrading FF for now, so I'll stick with that.
  • chrisjh777chrisjh777 Member Posts: 161 ✭✭✭
    There appears to be 2 threads relating to this matter (3DConnexion mouse not working correctly with Onshape). 

     I have a temporary fix, working consistently for me, documented in the other thread.  See Post 145 in this thread: https://forum.onshape.com/discussion/8449/3d-connextion-space-mouse#latest
  • EvanEvan Onshape Employees Posts: 43
    3DConnexion has released an updated driver for Windows that has resolved issues related to newer versions of Firefox.  You can find version 10.5.6 here:
    https://www.3dconnexion.com/service/drivers

    They are still working on an updated release for Mac.  If you would like to use newer Firefox on the Mac, you can get your Spacemouse working again by manually adding 3DConnexion's certificate in Firefox preferences:
    1. Start Firefox and go to its preferences.  (In the menu bar: Firefox->Preferences)
    2. Select "Privacy & Security" and browse to the "Certificates" section at the very bottom of the panel.
    3. Press the "View Certificates..." button.
    4. In the "Certificate Manager" panel, select the "Authorities" tab and press the "Import..." button.
    5. In the "Select File containing CA certifcate(s) to import" dialogue, go to /Applications/3Dconnexion/ directory and import the "root.crt" file.
    6. Close the "Certificate Manager" and the "Options" panels.
  • jackson_kingjackson_king OS Professional Posts: 77 PRO
    Thanks, @Evan!  This fixed it for me.
  • EvanEvan Onshape Employees Posts: 43
    Here's an update from 3DConnexion on the fix for the Firefox issue with macOS:

    We're following up on this thread to let you know that we are aware of the issues affecting our customers, users of Onshape in Mozilla Firefox for macOS.

    Although we have addressed the issue discussed here, we have had to delay the release due to unexpected quality issues. We're now targeting a release towards the end of June. This will be v. 10.5.3 of 3DxWare 10 for macOS.

    We're sorry for the delay. It's a disappointment to be taking this long to address a problem such as this.

  • NunoNuno Member Posts: 2
    3Dconnexion here.

    We're following up on this thread to let you know that we are aware of the issues affecting our customers, users of Onshape in Mozilla Firefox for macOS.

    Although we have addressed the issue discussed here, we have had to delay the release due to unexpected quality issues. We're now targeting a release towards the end of June. This will be v. 10.5.3 of 3DxWare 10 for macOS.

    We're sorry for the delay. It's a disappointment to be taking this long to address a problem such as this.
  • James_PetroskiJames_Petroski Member Posts: 1 PRO
    We are past the end of June now and there is no MacOS 10.5.3 driver released by 3Dconnexion, but I can say the addition of the root.crt file to the CA certificates does work to keep the mouse working in FF at the latest release (v61.0)
  • NunoNuno Member Posts: 2
    edited July 5
    Version 10.5.3 of 3DxWare 10 for macOS was released by 3Dconnexion today. The installer is available from the driver downloads page here.

    It includes support for recent versions of Mozilla Firefox, resolving the issue with the certificate installation.

    Again, we're sorry for the delay in addressing this issue and we're thankful for Onshape's assistance in getting this problem resolved.
  • s_p533s_p533 Member Posts: 1
    edited August 12
    Yes! Like above, but with details:

    I "added another app" in Control Panel\All Control Panel Items\Windows Defender Firewall\Allowed apps: 

    C:\Program Files (x86)\3Dconnexion\3DxWare\3DxNLServer\bin\3dxnlserver.exe

    Then it worked. Windows 10 Version 1709 OS Build 16299.248
    This worked for me. After adding the 3dxnlserver.exe to your firewall's allowed apps, restart all the 3d connexion services and Chrome/Firefox, or simply restart the pc!
  • samuel_hollandsamuel_holland Member Posts: 24 PRO
    edited August 14
    I'm having an issue with my 3D mouse where it will work if I hold the mouse in one direction for about 4 seconds. Then it will allow me to manipulate the model. If I let go of the mouse, it locks up after a second or so and won't work until a hold it again for a few seconds. 



  • jackson_kingjackson_king OS Professional Posts: 77 PRO
    I've run into this before.  I restart the drivers and it works again.  Are you using on a mac or windows machine?
  • samuel_hollandsamuel_holland Member Posts: 24 PRO
    Windows. I need to constantly restart drivers and open a new tab in the browser to get it to work
  • jackson_kingjackson_king OS Professional Posts: 77 PRO
    I know your frustration, been there many times myself. I’ve found it helps to unplug then plug back in the 3D connexion components before restarting the drivers. Their internal firmware seems to hang w/o a power cycle. You should be able to refresh your tab and have it work again, this is what I have to do to get it work again with chrome on a Mac. 

    There is always the ol’ Uninstall 3D connexion and reinstall the software. 

    Wish i had some magic fix for you but your among friends with this issue I’m afraid. 
«1
Sign In or Register to comment.