Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:

  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.


turan_aydinturan_aydin Member Posts: 11 ✭✭
Currently HTN (History Tree Names)  are in the following format
Extrude 1
Extrude 2
Revolve 1
Revolve 2
Chamfer 1
Chamfer 2
Fillet 1
Fillet 2 
and this actually  tell us only the type of the operation , yes we can rename them but this is time consuming
The suggestion is to have Names like:
Extrude 25mm
Revolve 30°
Chamfer 5mm 
Fillet 8mm
Thicken 2mm
Draft 3°
Rib 2.5mm
Shell 2mm
Hole M10mm
Boolean Union (Subtract or Intersect) 
Move 45mm (instead of Transform 1)
Copy 45mm (instead of Transform 2)
Modify fillet 8mm to 3mm
Move face 6mm
Offset surface 7mm
Plane offset 20mm
Helix 4 revolutions

Some of them will be repeated like
Fillet 5mm
Fillet 5mm
but this is better then Fillet 1, Fillet 2

At the end you still can rename it.



  • alessandro_cavolialessandro_cavoli Member Posts: 23
    I like this suggestion!!
  • lougallolougallo Member, Administrator, Moderator, Onshape Employees, Developers Posts: 1,666
    @turan_aydin Although it seems easy, this is not really a scalable option and there are many things that might no fit this naming convention. Building something that works for you might not work for everyone. Might be better to do this as a script that processes your tree bases on your formate for certain types.  I like the idea but not something we are going to do at this point.
    Lou Gallo / PD/UX - Support - Community / Onshape, Inc.
  • MBartlett21MBartlett21 Member Posts: 1,611 EDU
    What I'd like is Extrude to rename itself to Cut Extrude if it was cutting material away.
    I often have to look back in the extrude's definition to see whether it was a cut extrude or not
    MB - I make FeatureScripts: view FS (My FS's have "Official" beside them)
  • owen_sparksowen_sparks Member, Developers Posts: 2,312 PRO
    I'd still like the option to turn off automatic sequential naming and force the user to name the feature before accepting it.

    Production Engineer
    HWM-Water Ltd
Sign In or Register to comment.