Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:

  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Extrude-Remove up to surface

Miguel_GTMiguel_GT Member Posts: 8 EDU
Hi,

I go on trying OnShape and I would to do a extrude up to surface to remove solid.

In Inventor I used to select the surface directly, and it was recognices as only one surface.
Onshape selects the different parts of the surface and it doesn't be allow me to select all.



Thanks for any help

Comments

  • owen_sparksowen_sparks Member, Developers Posts: 2,259 PRO
    How have you made that surface?  Does up to next work? 

    How have you made the surface?
    As ever with a link to the document it's a lot easier to tell what's up...

    Owen S.
    Production Engineer
    HWM-Water Ltd
  • ilya_baranilya_baran Onshape Employees, Developers, HDM Posts: 919
    edited March 18
    You should be able to select the surface if you do "up to part" rather than "up to face".
    Ilya Baran \ Director of FeatureScript \ Onshape Inc
  • Miguel_GTMiguel_GT Member Posts: 8 EDU

    Thanks to both.

    Up to part worked. Thanks.

    Up to next didn't work.



    I've made the surface projecting edges of the base and then an offset. Finally, I extruded the curve as a surface.
    When I extrude, It doesn't recognize the curve as only one. Then, the surface neither. Maybe the problem is there.

    But up to part worked.

    Thanks to both again

  • Miguel_GTMiguel_GT Member Posts: 8 EDU
    edited March 19

    Hi,

    Another questions:
    How can I unshow (hide) the surface. Default geometry and sketches have the option Show (the eye).
    But with an operation I am not able to find something similar.
    With right button only see delete and suppress, but it's not what I need.

    Edited: I found, selecting the surface and right buttoon, Hide. But once hiden, to see it again only find Show all.

    With a hole, how can I select two edges to situate the hole. I tried with Mate conectors similar to you explained in other occasion.
    Like this: with two edges as linear references.




    Thanks a lot
  • Jake_RosenfeldJake_Rosenfeld Moderator, Onshape Employees, Developers Posts: 1,285
    @Miguel_GT

    Below the feature list there is a parts list.  In the "surfaces" section you will find your surface, and it will have the same eye next to it.
    Jake Rosenfeld - Modeling Team
  • KrzKrz Member, Developers Posts: 43 ✭✭
    Hole: make Sketch with point first - there you define your references
  • Miguel_GTMiguel_GT Member Posts: 8 EDU
    @Miguel_GT

    Below the feature list there is a parts list.  In the "surfaces" section you will find your surface, and it will have the same eye next to it.

    Thanks. I found it and worked.

    Krz said:
    Hole: make Sketch with point first - there you define your references
    I know that option. Inventor has it as well.
    But I look for the other option without a Sketch.

    Thanks to both.
  • owen_sparksowen_sparks Member, Developers Posts: 2,259 PRO
    Have a look at the previous update, it introduced the ability to use implicit mate connectors as sketch points.
    Production Engineer
    HWM-Water Ltd
Sign In or Register to comment.