Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:

  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Improvements to Onshape - February 11th, 2019

13

Comments

  • brucebartlettbrucebartlett Member, OS Professional, Mentor Posts: 1,878 PRO
    Loving assembly configurations!! Thanks!!
    Engineer ı Product Designer ı Onshape Consulting Partner
    Twitter: @onshapetricks  & @babart1977   
  • Andrew_Enslow_3DSAndrew_Enslow_3DS Member Posts: 40 PRO
    Thanks for the update! That assembly configuration is elegant. I'm also excited with that auto-complete and I didn't even know you could do conditions like greater than/ less than!
  • john_mcclaryjohn_mcclary Member, Developers Posts: 2,026 PRO
    Oh that's beautiful, thank you!

  • owen_sparksowen_sparks Member, Developers Posts: 2,385 PRO
    edited February 18
    TimRice said:
    @michael_corsetto
    Please update your 3DConnexion device drivers to the latest version and functionality returns to what you expected.
    My 3Dconnexion device works exactly as expected with the latest drivers.  By which I mean every time I reboot my machine it dies.  It has matched my expectation perfectly...
    Owen S.
    Production Engineer
    HWM-Water Ltd
  • 3dcad3dcad Member, OS Professional, Mentor Posts: 2,387 PRO
    edited February 18
    Yep, 3d mouse is a total mess at the moment.. Setting don't apply as they should and pan doesn't works at all. Same thing with old or new drivers. Could this be an Onshape issue after all? It used to work just fine with old drivers, only issue was sometimes not recognizing Onshape..

    FIXED with actually installing new drivers, not just downloading and thinking about installing.. =) =)
    //rami
  • owen_sparksowen_sparks Member, Developers Posts: 2,385 PRO
    Hi Rami.

    Eeek, that sounds horrible.  Mine only has 2 states, working perfectly or not working at all.

    Owen S.
    Production Engineer
    HWM-Water Ltd
  • 3dcad3dcad Member, OS Professional, Mentor Posts: 2,387 PRO
    edited February 18
    Is it possible that this update broke some 3dconnexion Space Mouse functionality? My Space Mouse stopped functioning on certain axis (pan up-down and left-right). The functionality was lost today. My Space Mouse has been great up until now.

    Thanks for the update! Auto-complete variables is great.
    I'm experiencing the same, no matter what drivers.. with pc and laptop

    FIXED with actually installing new drivers, not just downloading and thinking about installing..  
    //rami
  • 3dcad3dcad Member, OS Professional, Mentor Posts: 2,387 PRO
    If you wan't quicker way to add parts into drawings, please vote here:
    https://forum.onshape.com/discussion/11152/quickly-add-parts-into-drawing
    //rami
  • TimRiceTimRice Member, Moderator, Onshape Employees Posts: 220
    @3dcad @owen_sparks

    We unfortunately (or fortunately?) have little to do with the 3DConnexion integration. Please reach out to their support to diagnose the issues:

    https://www.3dconnexion.com/service/technical-support/support-formular.html
    Tim Rice | User Experience | Support 
    Onshape, Inc.
  • 3dcad3dcad Member, OS Professional, Mentor Posts: 2,387 PRO
    edited February 18
    @TimRice
    How is it possible that setup that has been working perfectly, suddenly stops working same time Onshape pushed an update? Could be coincidence but I don't believe in those  :#

    Could you 'open the hood' a little for this connection? I suppose Onshape does somehting with inputs, browser passes something and driver interacts somehow between device and software.. 

    FIXED with actually installing new drivers, not just downloading and thinking about installing..  
    //rami
  • EvanEvan Onshape Employees Posts: 49
    @3dcad - we did update a library supplied by 3DConnexion that interacts with their drivers. The updated library was designed to be backwards compatible with older 3DConnexion drivers, and should certainly work with the latest drivers. If you updated your drivers, my suspicion is that something went wrong with the install.

    I have sometimes had success by stopping/starting 3DxWare to get the system back into a better state:
     
    Doing this followed by a refresh of the Onshape page usually puts things right for me.

    Of course, this should not be necessary.  The support team at 3DConnexion will be better equipped to diagnose the root cause of the issue you are having.
  • 3dcad3dcad Member, OS Professional, Mentor Posts: 2,387 PRO
    edited February 18
    I'm very familiar with this weekly process to kill 3dx processes and restart driver, sometimes needs browser restart too.. But I never had such problems that only pan is not working, setting do not apply (reverse checkbox) and overall movement is very luggy.. The only problem used to be 3dx driver recognizing general browser instead of Onshape - now it's not that.. If I have time, I will post a new thread with some images/gifs later.. Let's leave this thread for hoorays for new functionality  B)

    -- Problems caused by old drivers, not backward compatible in my case.. FIXED with actually installing new drivers, not just downloading and thinking about installing..  
    //rami
  • john_mcclaryjohn_mcclary Member, Developers Posts: 2,026 PRO
    uh oh, I forgot who busted us ( @philip_thomas i think.. ) on spelling Onshape with a capital S, but someone better let 3dConnexion know! :)

    I had a problem with Onshape only, it was spinning on the wrong axis's 
    updating to the latest driver fixed it for me



  • NunoNuno Member Posts: 17 ✭✭
    edited February 18
    Hi @3dcad,

    3Dconnexion here.
    We can confirm the above statement by @Evan: the new library was designed to be backward compatible and was tested with older drivers. With that said, we cannot rule out that something is amiss and has somehow broken 3D mouse support in your set-up in your set-up.

    We also recommend to upgrade your 3D mouse drivers to the very latest version. The driver software can be freely downloaded from 3Dconnexion's web site. If you are facing an issue with the drivers, please follow @TimRice's advice and contact 3Dconnexion directly.
  • NunoNuno Member Posts: 17 ✭✭
    edited February 18
    Hi @owen_sparks,

    My 3Dconnexion device works exactly as expected with the latest drivers.  By which I mean every time I reboot my machine it dies.  It has matched my expectation perfectly...
    Owen S.

    That screen shot does look odd. If your 3D mouse is not being enumerated correctly by the system, it will not function in Onshape or any other program.

    Could you please get in touch directly with 3Dconnexion? We can try to track down what is the issue with the hardware.
  • NunoNuno Member Posts: 17 ✭✭
    edited February 18
    Hi @john_mcclary,
    uh oh, I forgot who busted us ( @philip_thomas i think.. ) on spelling Onshape with a capital S, but someone better let 3dConnexion know! :
    Fixed. Thank you for pointing that one out.
  • john_mcclaryjohn_mcclary Member, Developers Posts: 2,026 PRO
    Nuno said:
    Hi @john_mcclary,
    uh oh, I forgot who busted us ( @philip_thomas i think.. ) on spelling Onshape with a capital S, but someone better let 3dConnexion know! :
    Fixed. Thank you for pointing that one out.
     ;) 
  • owen_sparksowen_sparks Member, Developers Posts: 2,385 PRO
    Nuno said:
    Hi @owen_sparks,

    My 3Dconnexion device works exactly as expected with the latest drivers.  By which I mean every time I reboot my machine it dies.  It has matched my expectation perfectly...
    Owen S.

    That screen shot does look odd. If your 3D mouse is not being enumerated correctly by the system, it will not function in Onshape or any other program.

    Could you please get in touch directly with 3Dconnexion? We can try to track down what is the issue with the hardware.
    Thanks @nuno I'll be in touch once I've dug out my 3Dconnexion user details!  Device works fine until a reboot, then the device manager shows an unhappy SpaceExplorer.  The highly technical process of grovelling around on the floor, moving the toolbox, unplugging and re-plugging the USB cable fixes it!  It's a daily occurrence recently with all the windows updates requiring a restart.
    Cheers, Owen S.
    Production Engineer
    HWM-Water Ltd
  • NunoNuno Member Posts: 17 ✭✭
    edited February 18
    Thanks @nuno I'll be in touch once I've dug out my 3Dconnexion user details!  Device works fine until a reboot, then the device manager shows an unhappy SpaceExplorer.  The highly technical process of grovelling around on the floor, moving the toolbox, unplugging and re-plugging the USB cable fixes it!  It's a daily occurrence recently with all the windows updates requiring a restart.
    Cheers, Owen S.
    The folks in Technical Support are better qualified than me to track these sort of issues but here's a couple of suggestions.

    The scenario you described suggests a power supply issue: unhappy device after a reboot; re-plugging fixes it. This is not expected.

    If you're using an extension cord, try without. If that fixes it, you have a bad cord, probably dropping too much voltage on the line.

    If you're using an external USB hub, then try connecting the device directly to the machine, if at all possible.

    If the device is already connected directly to one of your machine's USB ports, try another as they are not all the same (due to different internal hubs, say).

    If none of the above helped, then the device likely has a hardware issue. Since it is an old device (3Dconnexion ended SpaceExplorer manufacturing back in 2013), there's not much we can do. Have a word with my Tech Support colleagues. They're good people.
  • owen_sparksowen_sparks Member, Developers Posts: 2,385 PRO
    @numo Thanks for the information, appreciate you taking the time.

    Cheers, Owen S.
    Production Engineer
    HWM-Water Ltd
  • 3dcad3dcad Member, OS Professional, Mentor Posts: 2,387 PRO
    Nuno said:
    Hi @3dcad,

    3Dconnexion here.
    We can confirm the above statement by @Evan: the new library was designed to be backward compatible and was tested with older drivers. With that said, we cannot rule out that something is amiss and has somehow broken 3D mouse support in your set-up in your set-up.
    Hi Nuno, thanks for stepping up - greatly appreciated!

    In my case, it seems that you also need to install drivers not only download.. [emoji_where_guy_bangs_his_head_against_the_wall] :flushed:

    I thought I already had new drivers once it started going off and thought I'd look at settings at some point.. now it seems that I actually didn't run the update just downloaded and then reinstalled old drivers.. 

    Backward compatibility didn't work for me, but with new drivers it seems to get back on track. Thanks for helping out! 
     
    //rami
  • NunoNuno Member Posts: 17 ✭✭
    edited February 18
    3dcad said:
    In my case, it seems that you also need to install drivers not only download.. [emoji_where_guy_bangs_his_head_against_the_wall] :flushed:
    Indeed. To interact with your 3D mouse hardware, you will need to download and install the drivers.
    I thought I already had new drivers once it started going off and thought I'd look at settings at some point.. now it seems that I actually didn't run the update just downloaded and then reinstalled old drivers.. 

    Backward compatibility didn't work for me, but with new drivers it seems to get back on track. Thanks for helping out!
    Good to know that you have sorted out the problem you were seeing.

    It's still a disappointment you were forced to download (and install ;-) a new driver version. It should have just worked and this is a concern to us (as we can't explain it and when we can't explain, it's a worry). On top of that, it affects our partners such as Onshape since they rely on 3Dconnexion to provide reliable drivers.

    Do you still recall what version you were using? If so, please let us know what it was as well as the basic system information (OS version, specifically). We'd like to collect this info to see if there's a pattern.
  • 3dcad3dcad Member, OS Professional, Mentor Posts: 2,387 PRO
    I was running W10 pro (ver 1803 / 17134.590) and 3DxWare64_v10-5-6_r2771
    //rami
  • NunoNuno Member Posts: 17 ✭✭
    3dcad said:
    I was running W10 pro (ver 1803 / 17134.590) and 3DxWare64_v10-5-6_r2771
    Got it. Thank you!
  • owen_sparksowen_sparks Member, Developers Posts: 2,385 PRO
    Thanks for the webinar yesterday. :+1:
    Any chance you could make a copy of that Computer Case file public?
    Cheers,
    Owen S

    Production Engineer
    HWM-Water Ltd
  • MBartlett21MBartlett21 Member Posts: 1,622 EDU
    @cody_armstrong
    When will the webinar be put on the webinars page?
    MB - I make FeatureScripts: view FS (My FS's have "Official" beside them)
  • john_mcclaryjohn_mcclary Member, Developers Posts: 2,026 PRO
    He said it would be a couple days, because the person who uploads is out of office
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 2,391
    Here it is for those that missed it:

     

    Neil Cooke, Director of Technical Marketing, Onshape Inc.
  • john_mcclaryjohn_mcclary Member, Developers Posts: 2,026 PRO
    thanks @NeilCooke

  • Henk_de_VHenk_de_V Member, Developers Posts: 150 ✭✭✭
    edited February 20
    @cody_armstrong,

    During the webinar (at 49:15) you was wondering if ternary operators could be nested.

    Here is the answer.




    Henk de Vlaam (NL)
Sign In or Register to comment.