Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:

  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Boolean not returning valid part

naregjannaregjan Member Posts: 6 EDU


I have a boat that I'm trying to model based off of four lofted sketches. I've been trying to hollow it out; I tried using both shell and thickness to do so. In either case, whenever I try to take the top of the boat off using any sort of boolean operation, I get an error. In this most recent iteration, I've got a 10mm thick shell, and when I try to get the intersection with a block I've extruded underneath it, I get an error. Here's the link

Why? How should I make it differently?

Comments

  • naregjannaregjan Member Posts: 6 EDU
    (also I realize this should probably be in "using Onshape," but I don't think I can move an already existent post)
  • naregjannaregjan Member Posts: 6 EDU
    Now posted here in a more appropriate venue, sorry 😅
  • philip_thomasphilip_thomas Member, Moderator, Onshape Employees, Developers Posts: 1,286
    @naregjan - Hello. In your screen shot Extrude1 is shown to be failing, but in the model it is succeeding! :)
    In fact, the entire Feature Tree has no errors! (well done) :)
    Philip Thomas - Onshape
  • MBartlett21MBartlett21 Member Posts: 1,581 EDU
    MB - I make FeatureScripts: view FS (My FS's have "Official" beside them)
  • owen_sparksowen_sparks Member, Developers Posts: 2,292 PRO
    @naregjan - Hello. In your screen shot Extrude1 is shown to be failing, but in the model it is succeeding! :)
    In fact, the entire Feature Tree has no errors! (well done) :)
    And herein lies the lesson of linking forum request posts to a revision of the doc not the live main workspace...
    [Patronising mode/off]

    Owen S.
    Production Engineer
    HWM-Water Ltd
Sign In or Register to comment.