Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:

  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Assembly does not update in context when created new branch

iveta_ivanovaiveta_ivanova Member Posts: 7 EDU
I have a document of an assembly with a part studio in context of this assembly. 
I made a new branch of this document, I made changes to the part studio which are updated in the assembly successfully. 
However, when I make changes of the assembly, they are not reflected in the part studio in context. 
What have I missed? 

Comments

  • john_mcclaryjohn_mcclary Member, Developers Posts: 2,114 PRO
    edited October 23
    Did you make sure to update the incontext reference?
  • iveta_ivanovaiveta_ivanova Member Posts: 7 EDU
    Hi, 

    Thanks for the reply. I already tried updating the context several times, it still keeps showing the one from the previous branch. 
    I also updated it from the Instances tab in the Assembly (left clicked on the part studio in Instances, Edit in context -> Update context) - still no change. 

    Also, from the same place, tried to go for New Context (Edit in context -> New context). It immediately takes me to the Part studio in context where it is set to Assembly contexts : None, but then it shows thethe updated Assembly, hooray.
    But when I use the dropdown menu to choose the Assembly name, it goes back to the old version, not updated, from the other branch. 

    I seems to be some bug because it doesn't make any sense :(  
  • john_mcclaryjohn_mcclary Member, Developers Posts: 2,114 PRO
    A new context will say none until you create a reference.

    Did you make sure one of the parts is set to primany instace?

    Part in asm will have a darker arrow icon
  • iveta_ivanovaiveta_ivanova Member Posts: 7 EDU
    Thanks, I didn't explicitly set a new primary instance for the new version.
    I watched a video about this and just now I tried clicking on the different parts in the Assembly, but I can't see "set as primary instance" for any of them.

    In the assembly the only black arrow I have is next to that part which I built in-context in the first branch (it says in-context references when I hover over it), but as far as I get the primary instance should be an existing part in the assembly, not the other way round? 

    I hope this makes sense... 
  • john_mcclaryjohn_mcclary Member, Developers Posts: 2,114 PRO
    Ok, so it should be as easy as opening the assembly you want, then right click the part in the tree with a dotted line arrow
    and choosing your new primary instance


  • KatieHuffmanKatieHuffman Member, Onshape Employees, Developers Posts: 75
    @iveta_ivanova
    The primary instance is the part that anchors the ghosted assembly in the Part Studio, and displays the solid arrow in the Instance list. Set primary instance is only available for parts that are created in a Part Studio which own a context. You should see arrows on any part in the Assembly Instance list that are in Part Studios which own contexts, a solid arrow on the part driving the context (primary instance), and dashed arrows on other parts contained in a multi-part Part Studio with the primary instance, known as secondary instances.

    You can right-click on an instance (in the assembly) with a dashed arrow to set is as the primary instance. Do you have a solid arrow on a part in the assembly? When you try to update the context do you get an error message of any kind, if so what does it say? If you don't have a primary instance and try to update the context it will say "Context assembly primary instance is not valid. Set primary instance of context before updating the assembly context" in blue across the top of the graphics area.

    Are you trying to update a context in a Part Studio that is on a different branch than the assembly? Workspaces on different branches are independent of each other, but you can merge them from the Document history.

Sign In or Register to comment.