Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.


rune_thorsen229rune_thorsen229 Member Posts: 156 EDU
Please make naming 'cascading' by letting new names being inherited from the generating process. 

I start with a sketch and give it a name, say 'gripper'
Then I extrude it, please let it inherit the name 'gripper' both as operation and resulting part so instead of the feature being named the useless 'Extrude #' then its called 'gripper' (anyway the icon tells what operation it is  so calling it Extrude is redundant).
The resulting part should also inherit the name 'gripper' instead of  'Part #' 
 It would really make the documentation a hole lot easier. 


  • tim_hess427tim_hess427 Member Posts: 308 PRO
    I would disagree with this functionality. Its not uncommon to do more than one extrude operation from any given sketch, so now I wold have a sketch and multiple extrudes all named "gripper". So, in this case, I like the generic names until I'm able to set them how I want. 

    In a similar manner its very common to have a part made up of multiple extrudes, revolves, and other features. How would Onshape know which feature name to use for the part? 
  • rune_thorsen229rune_thorsen229 Member Posts: 156 EDU
    tim_hess427 I don't get your point. As of now you get Part1....Part100. Better to have 'gripper1' to 'gripper100'. If you like the insignificant Part better and like to rename many times I suggest to put it as a toggle option in settings for people like you. 
    [Smart naming] /  [Nerd naming]
    Right  now a boolean of multiple instances results in the name of last instance right? 
  • brucebartlettbrucebartlett Member, OS Professional, Mentor, User Group Leader Posts: 2,042 PRO
    Like @tim_hess427 I regularly use a sketch for multiple extrudes
    Engineer ı Product Designer ı Onshape Consulting Partner
    Twitter: @onshapetricks  & @babart1977   
  • rune_thorsen229rune_thorsen229 Member Posts: 156 EDU
    edited March 11
    And you dont rename? Or do you like these insignificant redundant names? I don't understand the common attitude to be against improvements. I wonder if you were contrary to inferred constraints as well?
    Maybe my proposal is not clear enough?
  • tim_hess427tim_hess427 Member Posts: 308 PRO
    @rune_thorsen229 - I do rename my sketches and features. Also, its not that I like insignificant names, but I fear that "smart" names would be incorrect, causing more confusion than a name that's neutral. 

    Perhaps I'm not understanding your suggestion properly, but this is how I imagine that it would work based on your description: 
    Lets say I have a sketch named "Gripper". From that, I extrude two different gripper paddles and hinge pin. In a separate sketch named "Ribs", I design a couple of ribs that would be used to stiffen the gripper paddles, and extrude the ribs so that they merge with the paddles. Now, following your suggestion, I have a hinge pin named "Gripper 3" and two gripper paddles named "Ribs 1" and "Ribs 2". If I understand your suggestion correctly, the smart names are actually misleading. 

    I'm certainly not against improvements, but I think a simplistic "feature gets the referenced sketch name" doesn't add much value because the relationship between features and sketches is not 1-to-1. An extrude could reference multiple sketches, and multiple extrude features could reference a single sketch. So, any naming logic would have to make so many assumptions that it could easily create names that are confusing. 

    Also, development resources being limited... I would prefer other improvements be prioritized over this one. 
Sign In or Register to comment.