Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Assembly parts lost and some reorient when Importing assembly into another assembly

john_mardirosian229john_mardirosian229 Member Posts: 15
What Seems To Have Gone Right:
I created a wheelchair. I started from a copy of a sports wheelchair, since it gave me a chance to learn about Beams. The sports wheel chair was created by Shandon Simms and is at Sports Wheelchair - 8 | Wheelchair (onshape.com). I made a copy locally and also imported that into the cabin without issue (see Cabin | Cabin Solid Handicapped - Sports Chair (onshape.com)). In writing this post, I just realized that I cannot tell which instance (the original or my copy) is actually in the cabin. I'll have to learn how to figure that out. But for now, it doesn't matter.

I finished making a more standard wheelchair, creating an Assembly with the frame, wheels, castors, etc. It looks perfect as a stand-alone assembly. All the fasteners are in place to secure all the Part Studios. I did observe some really strange behaviors when importing the wheels. I have them in the Assembly from the Import and when I clicked a Mate from the tool bar, the wheels suddenly jumped to the center of the Assembly. Other Part Studios or Assemblies of my own making did not exhibit that "jump" behavior. Anyway, I managed to get all the fasteners in place and the final Standard Wheelchair looks perfect.
Wheelchair | Wheelchair (onshape.com)

The Problem:
I made a Duplicate of the previously successful cabin with sports wheelchair project and deleted the sports wheelchair and imported my own standard wheelchair. The following image shows what happened. The icon in the Import panel shows a partial standard wheelchair (I've noticed significant delays in the icons catching up with the actual completed work, so maybe that's nothing) and the actual import results in:
  • A partial set of parts
  • Appearance values lost
  • The wheel jumped back to the center of the assembly
  • Fasteners for that assembly are not constraining me from moving any of the imported parts around.

 I was expecting to be able to Import my standard wheel chair, move it in place roughly, and then, as before, use a fastener to lock it to the cabin floor. Can anyone tell me what I'm doing wrong?

Thanks,
John

Comments

  • wayne_sauderwayne_sauder Member Posts: 129 PRO
    Create a version of your Wheelchair.

  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 3,838
    Take heed of the big blue message in the insert dialog. Versions must be made in linked documents for them to update in other docs. You are inserting an old version. 

    The wheelchair was originally made by me by the way 😊
    Director, Technical Services, EMEAI
  • john_mardirosian229john_mardirosian229 Member Posts: 15
    Wayne, Yes, on creating a version. Seeing that as a "best practice" in Forum Post Checklist (Read this First) — Onshape, I did exactly that as soon as I finished the post. I think I have done that correctly, but this would be the first time I have created a version.

    Neil, Awesome sports wheelchair. Sorry I did not pick up on your authorship. To my problem, I would be OK if the version I took fell out of staying "current", as I am not sure I need (or want) additional changes. With my willingness to lock to an older version in mind and as a new user, I am not sure how to interpret your guidance. Are you saying I need to link my Cabin with Wheelchair document to something? If so, why didn't I see the problem when first Importing the Sports Wheelchair?

    In an effort to make use of your guidance, I went to repeat the exercise of importing my standard wheelchair and to look for the "big blue message in the insert dialog". I didn't see it.


    Also, once imported, the Standard Wheelchair now rotates and translates into place without and disassembly strangeness.


    I tried to follow the Forum direction, apply a version, and then wait for some help from people like yourself. I made no changes since the post, yet the issue seems to have disappeared. I would certainly appreciate understanding a bit more about linking my document or any other comments you might offer.

    Regardless of this seeming to have gone away, I appreciated so much your Sports Wheelchair and how helpful it was to have a cool example of beams. So far, my model is not actually foldable, like most "real" standard wheelchairs, as it started with the solid beam across the axles. But if I can be sure that I'm not introducing some kind of linked document problem for others, I will think about sharing the Standard Wheelchair model publicly (I think all my stuff is already public, but maybe I have to "post" the model. 

    p.s., I have read some documentation about linked documents at Linking Documents (onshape.com)
    The text "For example, an assembly in Document A can instance a part defined in version V1 of Document B" made me think I was OK to "grab an instance" and be free from any subsequent revisions by the creator. Maybe that is not correct.
  • john_mardirosian229john_mardirosian229 Member Posts: 15
    Wayne, Yes, on creating a version. Seeing that as a "best practice" in Forum Post Checklist (Read this First) — Onshape, I did exactly that as soon as I finished the post. I think I have done that correctly, but this would be the first time I have created a version.

    Neil, Awesome sports wheelchair. Sorry I did not pick up on your authorship. To my problem, I would be OK if the version I took fell out of staying "current", as I am not sure I need (or want) additional changes. With my willingness to lock to an older version in mind and as a new user, I am not sure how to interpret your guidance. Are you saying I need to link my Cabin with Wheelchair document to something? If so, why didn't I see the problem when first Importing the Sports Wheelchair?

    In an effort to make use of your guidance, I went to repeat the exercise of importing my standard wheelchair and to look for the "big blue message in the insert dialog". I didn't see it.


    Also, once imported, the Standard Wheelchair now rotates and translates into place without and disassembly strangeness.


    I tried to follow the Forum direction, apply a version, and then wait for some help from people like yourself. I made no changes since the post, yet the issue seems to have disappeared. I would certainly appreciate understanding a bit more about linking my document or any other comments you might offer.

    Regardless of this seeming to have gone away, I appreciated so much your Sports Wheelchair and how helpful it was to have a cool example of beams. So far, my model is not actually foldable, like most "real" standard wheelchairs, as it started with the solid beam across the axles. But if I can be sure that I'm not introducing some kind of linked document problem for others, I will think about sharing the Standard Wheelchair model publicly (I think all my stuff is already public, but maybe I have to "post" the model. 

    p.s., I have read some documentation about linked documents at Linking Documents (onshape.com)
    The text "For example, an assembly in Document A can instance a part defined in version V1 of Document B"
  • john_mardirosian229john_mardirosian229 Member Posts: 15
    This issue is resolved.

    Applying a version to the Part Studio and Assembly in the destination for the imported assembly seems to have eliminated the issue.
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 3,838
    That's correct - I was referring to your previous post with the insert dialog image where it says "337 changes since last version" - linked docs work with versions and will not update until a new version is created. Glad you got it sorted.
    Director, Technical Services, EMEAI
Sign In or Register to comment.