Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

DXF Export Issues

jason_traudjason_traud Member Posts: 13
I'm trying to get a DXF file exported from a part and then import it into Carbide Create in order to cut it on a CNC. My issue is that the software I'm importing it into seems to be interpretting the MM units in OnShape as inches. I can manually scale it down however, the final scaling appears slightly off. 

I'm new to the DXF format, but could there be a line in that specifies units that's not being generated properly or is omitted? I'm working with the face of part 19 in the project below
https://cad.onshape.com/documents/33b9bc333fda92b9d1e79d9c/w/e88e5eb22a9dc4d818e7335d/e/9feb284ab86b9ecd4fb5cef1 

Comments

  • tim_hess427tim_hess427 Member Posts: 648 ✭✭✭✭
    This thread has some discussion on the topic. If I remember correctly, DXF files are supposed to be unitless, but different softwares try to guess the units and often guess differently from other software. If you open the DXF in a text editor, you may be able to find something to tweak. 

    https://forum.onshape.com/discussion/comment/72481#Comment_72481
  • jason_traudjason_traud Member Posts: 13
    Thanks! I've reached out to Carbide3D and they apparently don't do scaling. The workaround I was able to do is changing the workspace units to inches in OnShape, then re-exporting the DXF and importing that file. Then restoring the MM setting in the workspace. 
  • edward_petrilloedward_petrillo Member Posts: 70 EDU
    I had a similar issue with a waterjet quoter (andymark .com).  The response below from Drew at Onshape support   solved the problem; it appears that the DXF version you choose in the export dialog is critical: it must be 2018.

    Thanks for reaching out to Onshape Support. Sorry for the late response - I spent quite a bit of time digging into this one to determine what is happening here, and I should have an answer.

    AndyMark's warning about the $INSUNITS field is due to their DXF reader trying to guess the units of a dimensionless DXF. The $INSUNITS field is not meant to specify units of a drawing - according to Autodesk's website, it's used "Specifies a drawing-units value for automatic scaling of blocks, images, or xrefs when inserted or attached to a drawing". Because of this, not all programs set it to match the units, so it can end up scaling parts up or down.

    To get your current part into the AndyMark Waterjet importer, you'll want to make sure your workspace unit is inches. Click on the flat face of the part, right-click, and select "Export DXF/DWG". When the dialogue box pops up, you'll want to make sure that the version you choose is 2018. After that, it should import into the waterjet importer just fine.

Sign In or Register to comment.