Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Fillet Width Measurement Option Fails Randomly

VinceHaley_SkillCoachVinceHaley_SkillCoach Member Posts: 11 ✭✭
Quick question, I'm having way too many instances where the "width" option on the fillet tool fails to run. In most scenarios I consider the geometry to be straightforward. In the example below I tried adding the fillet to both solid and surface geometry. If I change the measurement option to radius the fillet will work on the example geometry.

Are there any known issues are limitations? 






Thanks in advance,
Vince Haley
SkillCoach
Vince Haley
Creative and Technical Skill Development Coach
Design Inspiration
LinkedIn Bio

Answers

  • S1monS1mon Member Posts: 1,057 PRO
    Using a width measurement with an oblique angle like this, you're falling off the edge of the base surface because the nominal width of your 0.437 radius is much less than the 0.375 or 0.5 widths you tried. You either need a smaller number, or extend the end of the surface first and trim back after.

    Whenever a fillet fails, try a much smaller number and sneak up on the failure so that you understand what's happening.
  • VinceHaley_SkillCoachVinceHaley_SkillCoach Member Posts: 11 ✭✭
    @S1mon, unfortunately, no matter what size fillet I use the feature still fails. I even tried pre-rounded the horizontal edges first.


    Vince Haley
    Creative and Technical Skill Development Coach
    Design Inspiration
    LinkedIn Bio
  • S1monS1mon Member Posts: 1,057 PRO
    Interesting. If you can make your doc public, maybe there's a work around. I would expect that adding the rounds to the horizontal edges first would make things harder to do.
  • Evan_ReeseEvan_Reese Member Posts: 1,532 PRO
    Just did a quick mockup of a similar situation and it's failing too. Feels like a bug or something: https://cad.onshape.com/documents/3d1f8bdb3048979813421d61/w/5b152d596597476ea8de8abe/e/9ff38b23151bf52938546d94
    Evan Reese / Principal and Industrial Designer with Ovyl
    Website: ovyl.io
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 4,496
    Yeah, please file that as a bug. The fact that chamfer works fine means that the underlying geometry is not at fault.
    Director, Technical Services, EMEA
Sign In or Register to comment.