Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Workbench background issue

MoonMoon Member Posts: 6 EDU
Hi,
I am new in onshape and trying to get introduced with the paltform.
Like other discussion threads, I am also facing the issue "Dark workbench background".
I tried with edge and also chrome but did not resolve the problem?
Can anyone help me to bring it into 'light'?

Best Answer

  • MoonMoon Member Posts: 6 EDU
    Answer ✓
    Hi everyone !
    I got the problem solved. This works for me by the way below:
    First, I checked if my graphics card is blacklisted or not, after ensuring that it is not,
    I checked if my browser supports WebGL by going through this link https://get.webgl.org/
    Then, I went to chrome://settings and ensured that hardware acceleration is turned on.
    Afterwards, chrome://flags and search for my WebGL version but didn't find any.
    Finally, I enabled the Override software rendering list and relaunched chrome and found my workbench light.
    However, this is not the recommended way as mentioned in different online tech articles.
    I am not sure what problems I going to face for this change! After all, it works. 

Answers

  • Axel_KollmenterAxel_Kollmenter Member Posts: 259 PRO
    Hi @Moon sadly you cant change your workbench color at the moment.
    Best regards,

    Axel Kollmenter
  • chadstoltzfuschadstoltzfus Member, Developers Posts: 84 PRO
    There is currently no Onshape-supported way to do it. I personally use the Chrome Extension, Dark Reader. It works relatively well, sketches might be a bit hard to see for some and it has some quirks when editing features, but it's better than staring at a white screen all day long. 
     
  • Axel_KollmenterAxel_Kollmenter Member Posts: 259 PRO
    There is currently no Onshape-supported way to do it. I personally use the Chrome Extension, Dark Reader. It works relatively well, sketches might be a bit hard to see for some and it has some quirks when editing features, but it's better than staring at a white screen all day long. 
     

    Are your sketch lines still blue and black? or does they change to another color too?
    Best regards,

    Axel Kollmenter
  • MoonMoon Member Posts: 6 EDU
    Thanks for all of your responses.
    Should I try some other browsers? Specifically, is this problem related to the browser configuration or my PC's hardware configuration?
  • john_mcclaryjohn_mcclary Member, Developers Posts: 3,708 PRO
    Usually when Onshape goes black without you doing it with an extension like dark reader. It means the video driver has failed, or the webGL crashed.

    can you show a screen shot of your results from
    Compatibility check (onshape.com)

    We're looking to see if all the check marks are green and your GL renderer is what you are expecting. (on a laptop it may be your integrated graphics like Intel, if you have the option for a discrete card you may have to set your browser up to always use it. In my case you can see it is set up to use the nVidia card)


  • chadstoltzfuschadstoltzfus Member, Developers Posts: 84 PRO
    Are your sketch lines still blue and black? or does they change to another color too?

    Yes, the sketch lines will still resolve to blue and black. 



    Part/face colors remain intact as well. Of course, you could run into some visibility issues if you color your parts black/charcoal. 


  • MoonMoon Member Posts: 6 EDU
    It is attached below:

    Is this alright? Should I configure anything?
  • S1monS1mon Member Posts: 982 PRO
    @Moon

    The overall performance looks very low (less than 1% of what top machines are doing these days). There may be some browser settings which can help. Click on the "Graphics Performance Recommendations" link and follow the instructions.
  • Axel_KollmenterAxel_Kollmenter Member Posts: 259 PRO
    Are your sketch lines still blue and black? or does they change to another color too?

    Yes, the sketch lines will still resolve to blue and black. 

    ...

    Part/face colors remain intact as well. Of course, you could run into some visibility issues if you color your parts black/charcoal. 
    ...


    Aah thanks. I don't think that's good. Then I have to look very carefully every time where my lines are. I think with the bright background you save some time.

    Best regards,

    Axel Kollmenter
  • MoonMoon Member Posts: 6 EDU
    Answer ✓
    Hi everyone !
    I got the problem solved. This works for me by the way below:
    First, I checked if my graphics card is blacklisted or not, after ensuring that it is not,
    I checked if my browser supports WebGL by going through this link https://get.webgl.org/
    Then, I went to chrome://settings and ensured that hardware acceleration is turned on.
    Afterwards, chrome://flags and search for my WebGL version but didn't find any.
    Finally, I enabled the Override software rendering list and relaunched chrome and found my workbench light.
    However, this is not the recommended way as mentioned in different online tech articles.
    I am not sure what problems I going to face for this change! After all, it works. 
  • SethFSethF Member Posts: 89 PRO
    @Axel_Kollmenter I use the same extension (Chad recommended it to me several months ago). It has some settings you can play with for contrast and what not. I think it works great for everything besides drawings. So I have it on most of the time (until there's a day I'm doing a lot of drawings).

Sign In or Register to comment.